Normal direction and extra faces problem brep - mesh conversion

I have suceeded to make a difinition which exchange specific triangle pairs in a mesh to a quad. My problem is when I try to reassamble the breps to create the modified mesh , unnecassary extra faces are generated and the normals are facing inside and outside randomnly, despite I am using the unify normals widget. What is the remedy for this?

normal and extra faces (36.3 KB) (42.8 KB)

P.S. With or without a bottom (before or after Cap Holes): (39.7 KB)

Happy New Year Joseph! Thank you!
Actually I am really confused. As far I can see if make the brep closed it is fiixing the normals. I dont undestand why. Also what can I do if want it open? Only way is to make it closed and then delete the faces I dont want?
Second thing I dont undestand why the simple triangle brep elements has multiple faces? Can it be simplified?

See version ‘b’ in the P.S. of my previous post. The bottom (Cap Holes) is optional.

I didn’t see any duplicate faces or modify your geometry at all. That’s what I used the yellow group for in version ‘a’, to visualize each of the three lists separately and verify they didn’t overlap. Baked them to confirm. It just seems to work better using Brep Join first before converting it to a mesh.

I have discovered that the mesh I generated and baked this way has problems. I turn on the vertes points we can see the that every triangle has separate vertex point. I know that I can use “weld selected vertecies” command in Rhino to unify them but it is quite tedious job to do with all teh verex points. Is there another way to join the brep elements in Grasshopper so that they have common edges end vertecies?

BREP JOIN.3dm (103.4 KB) (41.7 KB)

I don’t understand? What’s the .3dm file for? (42.4 KB)

Nothinging special, you can save time avoid baking. :slight_smile:

You could also use weaverbird plugin.

normal and extra faces (37.4 KB)

Hi Kim,
If you check the last Mesh ( BREP JOIN.3dm) you can see that it has mutiple ovelapping vertices.

There’s nothing I can do for you with this mesh. Just avoid the way how you made this mesh with…