No class derived from CRhinoPlugIn in plug-in file

Ok just a quick update.

The computer on which ExactFlat DOES work is running the same version of Rhino as the computer that does not work.

The customer disabled all plug-ins that do not ship with Rhino. ExactFlat still does not load and gives the same error message.

Another update. My customer just told me he did a system recovery and now ExactFlat is working. At this point I’m guessing it was a Windows Update that screwed things up? My customer is going to try to remember what was done to the computer before ExactFlat stopped working and let me know if he finds the problem.

-Luke

Well that is a little worrisome. I wonder why your plug-in and not others (just thinking out loud). How can I get a copy of your plug-in?

Hi Dale,

You can download the 64-bit installer here:

This is for the same version used by the customer. I’ll send you an updated link tonight after I rebuild the plug-in using the newest Rhino 5.0 SDK.

Please let me know if you have any questions about the plug-in.

Well, your plug-in installs and load in Rhino 5 x64 on my Windows 8.1 developer box, which is always up-to-date with Windows Updates. So much for that test…

Luke, is your customer running Windows 8.1?

Windows 8.1.

Here is the link to the new build using the Rhino 5 SR9 SDK. I’ve sent it to my customer to see if this makes a difference. I’ll let you know what he says.

FYI: We have observed that exact behavior on Windows 8.1 with the VRayForMatrix plug-in from Chaos Group. And it was in fact a Windows Update that caused the problem.

You have no idea how happy it makes me to hear that I’m not the only one experiencing this with my plug-in!

Do you remember which update caused things to stop working?

We were using 5.0 64 bit SR9.

Hello McNeel!

VRay for Rhino is not loading since the last Rhino build.
The folks at Chaos Group tried to troubleshoot my machine without success.
They could not determine if the issuse were on the McNeel, Microsoft, or Chaos Group side.
Please help. I am on Windows 8.1 Pro.

Best,
Claudio

Hi Claudio,

I’ve had a few additional customers contact me with this problem, one even quoting this thread. In all cases, the problem went away after performing a system restore. I can’t guarantee that your problem is the same, but it looks to me like one of the Windows Updates is doing something to cause this.

It’s possible that restoring your computer to an earlier state may fix the problem (by undoing the Windows Update). If you do try this and it works, would it be possible to post a list of the updates that were undone?

-Luke Niwranski

Thanks Luke. Can you point me to a reliable resource on how to restore to earlier states?
Will doing so affect my Rhino or Vray installs?
Claudio

Hi Claudio,

Here is a link to Microsoft’s website that describes what system restore is and how to use it. You need to know that this is performing changes to your computer that may change the behaviour of installed software. It is possible that this may cause more problems than it will solve. Please keep this in mind when making a decision.

Also, the link below describes three procedures. The one you would be interested in is System Restore. This will simply restore your computer to an earlier restore point.

http://windows.microsoft.com/en-ca/windows-8/restore-refresh-reset-pc

-Luke

Hi all,

This is Peter Newman from Uformia. We ran into this issue with our plugin on one persons machine. They are running Windows 8 (not 8,1) but appeared to have the same issue.

We identified the issues as caused by an entry in the Windows registry:

In the registry folder:
HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers

There is an entry:
“C:\Program Files\Rhinoceros 5.0 (64-bit)\System\Rhino.exe”="$ IgnoreFreeLibrary<symvol.rhp>"

(Where symvol.rhp is our plugin.)

Deleting this entry allowed the plugin to install/load correctly. It appears our plugin triggered some Windows compatibility behaviour somehow (maybe a crash during loading or unloading or something), which then got in the way of the process Rhino uses to load plugins.

Hopefully this helps.

2 Likes

All,

I think this might be caused by altering the AssemblyInfo.cs file.

I have not looked extensively but this error can be reproduced when more than one culture is added to the list.

I just had another customer come to me with this exact same error. We had a look at the HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers key and sure enough it contained an ExactFlat value. After deleting the value and restarting Rhino, everything was working as it should.

How did you ever find this?

Thanks!

I’m so glad to find this thread and to get my Vray for Rhino 2 running again, that stopped to work this morning.

I reinstalled a higher version, then this problem disappeared.