"Never Repeat these Commands" does not save

i never paid much interest to this accept _MaxViewport and occasionally _SetDisplayMode, which i had added several times, actually believing that it would now be the last time i would have to add it. i first thought this might have occurred due to some freezing of rhino so i intentionally quit rhino now the intended way to see if this command keeps saved.

i think i have this problem for a few versions already. honestly i also cant remember that it ever saved anything added to the list. anybody else seeing this?

Hi Richard - I see that - it sticks in the current session only, here, is that what you see?

https://mcneel.myjetbrains.com/youtrack/issue/MR-3179

-Pascal

1 Like

This should be fixed in the latest RhinoWIP (5E326w). Give it a try.

Something got unfixed for me, repeating a command after a view change no longer works for me. Used to behave not like this for me.

Tried adding _SetDisplayMode, SetDisplayMode and '_SetDisplayMode to never repeat these commands but none of those commands seem to register to that list.

I am running RhinoWip 5E334w

Very strange. I’m not able to reproduce this one on my machine with 5E334w. It’s working as expected for me:

When you add them to the list? Do they just disappear? What exactly happens when you are adding them in Preferences > General > Never repeat these commands? Do they show up, but when you close the Preferences dialog and re-open it, they do not appear?

Hi Dan, they are saved on the list and stay there also after reopen or relaunch. It’s just they have no effect.

Previously I never noticed commands not repeating after view changes. That’s why I went up to that list to add them and noticed it had no effect.

Tested this on two different macs, one on Sierra the other High Sierra, both running 5E334w.

How are you changing the display modes?

Are you changing the Display Modes on the viewport by right/option-clicking and selecting Shaded, Wireframe, etc from the context menu?

The standard shortcuts ^ CMD R, ^ CMD S, ^ CMD W

Try adding Shaded, Wireframe, etc. to the “Never repeat these commands” list.

I added it like this.

27

Had no effect, in my opinion this should be a standard function though, as you can not repeat changing a view anyway. I often work in wireframe, or shaded to select edges and run a command and see what it looks like in the rendered mode and rerun the same command before SetDisplayMode. I think that worked before, might be wrong though.

Interesting. I did the following test:

  1. Add Shaded and Wireframe to the “Never repeat these commands:” list.
  2. Start new modeling window.
  3. Run Box.
  4. Press space to repeat the Box command.
  5. Right-click the viewport, select “Shaded” from the drop down list.
  6. Press space to repeat the last command.

Expected result: The Box command repeats.
Actual result: The Box command repeats.

Next, I did the following:

  1. Start new modeling window.
  2. Run Box.
  3. Press space to repeat the Box command.
  4. Press command+control+S
  5. Press space to repeat the last command.

Expected result: The Box command repeats.
Actual result: The Shaded command repeats.

Do you see the same behavior?

Yep, same behaviour. Now don’t tell me this is a fix, haha. Wouldn’t want to go back to the right-clicking viewport era.

Actually, I think I’m an idiot above. Shaded and Wireframe are not commands. Doh. Of course they would not repeat.

No, this is not a fix. I don’t have my head screwed on straight today…so I’m trying to fix that before I figure out what has broken in Rhino.

Ok thanks for looking into it.

Ok, I think I’m getting closer here. Apologies for the flailing.

In Rhinoceros 5.3.2, if I do the following steps:

  1. Add SetDisplayMode to the “Never repeat these commands list:”
  2. Start a new modeling window.
  3. Run the Box command and draw a Box.
  4. Press command+control+S to switch to Shaded mode.
  5. Press space to repeat the last command.

Expected result: The Box command runs.
Actual result: The Box command runs.

whereas if I repeat the above steps in RhinoWIP (5E334w), I get:

Actual result: "Display mode set to “Shaded.”

I think I’m finally catching up with the original reported regression here.

@pascal Can you sanity check this on your machine please?

Ok, I’ve logged this in MR-3188. Thanks @Niels

This should be fixed in the latest RhinoWIP for Mac 5.4 (5E366w). Please give it a try. Happy New Year!