Model not saving whitelist domain entries

Hi, I am trying to add domains to my model, but it is not working. The “allow domains for embedding” lets me enter a website (“https://jsfiddle.net/” for example) and it turns blue, but then my jsfiddle page example gives the error “session initialisation failed.” When I revisit the “edit” page for the model, it does not show any domains in the domains box and has not saved them. Is this an error on my end or in the “allow domains for embedding” box?

Add only full domains to the list (that is the hostname part of your URL, including the port number if you are using a non-standard one, i.e. everything after https://), more on this documentation page. The input box for the global domains should look like this:

Update: The JSFiddle iframes use a different URL and you need to whitelist fiddle.jshell.net.

Thank you for your help on this, Pavol. I have followed the whitelist instructions and your explanation as well. My domains for embedding options look a little different, though. There is a spot for global and additional domains.


When I put the site in the spot for global domains, it does not save the site, but it does save the site in the spot for additional domains. Not sure if this matters. I am still getting the “initialisation failed” message. I have my model view server set to ‘eu-central-1’ but I am in the US east coast and have tried ‘us-east-1’ and ‘us-east-2’ to no avail. I am using the code from the “direct embedding” example here and have inserted my ticket for my model “box sample.” When I use Shapediver’s sample ticket of the couch example, the session works. But not for mine. I am stumped.

To set global domains, go to https://app.shapediver.com/me#domains , set fiddle.jshell.net there and hit the Update domains button.

Keep the modelViewUrl: 'eu-central-1' setting as is JSFiddle code and try again.

Alternatively, you can try embedding your model with our CodePen examples, simply set cdpn.io and codepn.io in the global domains and replace the model ticket in the code.

Thank you for the help on the global settings. I have added those three to my global and it saves. I have used the CodePen examples and, as you said, just added the cdpn.io and codepn.io to the domains, and it still does not show my model. My Google Chrome is up to date as well. Still stumped?

Which ShapeDiver account do you use for the embedding?

the username Stephanie B using the gmail email. it is also associated with my Karamba license

My apologies for misunderstanding, I gave you wrong answer earlier.

The code examples are set up for the main platform but your Karamba enabled account is on the test system so you need to change the model view URL to this:

modelViewUrl: "https://sddev.eu-central-1.shapediver.com",

Also don’t forget to replace the model ticket.

Let me know how you getting on.

Changing the model view URL worked! Thank you so much! I am so relieved!

1 Like

Hi Pavol, I am running into a similar problem with a new model in a new website. I have my domains entered in my global domains tab in my dashboard. I try to click the box “use all global domains” in the model’s settings and save the model settings, but when I open the model settings again, the box does not stay checked. Also, the model produces a new ticket every time I open the model. Not sure what is happening? The model is “Tower 7_16 a”

I just checked the settings for the model you mentioned and global domains are allowed for embedding.

I hope the embedding works for you now but let me know if it doesn’t. More on global domains it the Documentation:

Read more about the latest tickets update in this Forum post:

Thanks for your help, Pavol. It is working!