Mesh UV export problem

texturemapping
mesh
unhandled
export
stretch
uv

(K Lukyanov) #1

Hello everyone.
I’ve noticed some UV bug when exporting hi-poly meshes (problem almost gone when exporting lo-poly meshes). For example, I created an object and convert it to hi-poly mesh. Then, I import exported object back into Rhino (or any other 3d software) and see some strange “stratched” verticles (hilighted lines) in the UV map.

Problem appears on both Rhino 5 and Rhino 6 beta.


(Jussi Aaltonen) #2

Hi @k.lukyanov,
Are the UV’s correct if you save and load your model as 3dm instead of exporting + importing?
You used Unwrap to generate the UV’s right?


(K Lukyanov) #3

HI!

  1. Yes, everything is fine when I save and open again .3dm file (also, everything is ok when I import .3dm file into rhino).
  2. Yes, I used Unwrap tool for creating UV map.

I should say, that when I unwrapping mesh created in rhino in other 3d-softwere everything in fine, even when I import unwrapped mesh back into rhino.


(Jussi Aaltonen) #4

I would like to take a look at that model to see which part of the mesh those highlighted parts come from. Could you @k.lukyanov upload the file here?
I’ve logged this issue. It may be related to UVW map exporting to FBX.


(K Lukyanov) #5

No problem.
UV Problem.3dm (3.1 MB)


(Jussi Aaltonen) #6

This happens when texture coordinates are set on the mesh object using the custom object mapping. After applying texture this problem is visible already on the “Good” mesh object where the sphere bottom meets the box:

This becomes visible in UVEditor only after mesh is imported back to Rhino because at this point the custom object mapping needs to be re-created from the texture coordinates that are set on the mesh (texture coordinates are imported and exported but the custom mapping object is not).


(Jussi Aaltonen) #7

Filed a new bug for this: https://mcneel.myjetbrains.com/youtrack/issue/RH-43051


(K Lukyanov) #8

Well, thank you so much for helping me figure it out. Now, when I apply texture I see this issue.
Hope, this bug will be resolved.


(Brian Gillespie) #9

RH-32866 is fixed in the latest Service Release Candidate
RH-43051 is fixed in the latest Service Release Candidate


(K Lukyanov) #10

I’m affraid, that it’s not fixed :frowning:
Again, after export and import back in Rhino, some vertices at wrong places.



Issue.3dm (7.4 MB)


(K Lukyanov) #11

So, after a year and a half, I was able to figure out how to avoid this problem.

Let’s look at this step by step:
1. Create simple object (mostly this bug appears in spherical shapes)

2. Create custom mapping (I’ve unwrapped objects by cutting it every seam)

3. Create custom mesh and export it

4. Import back this mesh and check UV mapping

Now, you can see the problem.

From this point starts most interesting things…

I’ve noticed, that created UV island not matching mesh shape (before exporting).

So, I’ve decided to setup mesh settings in the preferences first.

Then you need to recreate your UV mapping and export mesh (this is important) with the same settings as the settings in the properties.

In the end we can have perfect UV map:

Summarizing all the above:

before we create our custom UV mapping we need to setup custom Render Mesh Quality in the Preferences and after that we need to create or export mesh with the SAME SETTINGS as the Render Mesh Quality settings in the preferences. After that no UV problem will be appears. Mesh displayed in the UV map should be identical with the export mesh.


(David Eränen) #12

I’ve re-opened the YouTrack item.