Mesh split losing part of mesh?

Hi everyone,

I’ve generated an isosurface based on perlin noise. This gives me a (fairly complicated, I guess?) mesh. I’m now trying to split this mesh into cells in order to study it. I first tried using boxes to split the mesh but that didn’t work very well so I’m now using planes. So far it seems to work OK except for one major caveat: the mesh split component at the very end of my definition seems to output invalid meshes for certain cells.

I’ve tried a number of workaround without success. Does anyone have any clue what’s going on here?

If anyone can think of a simpler way for me to achieve what I’m trying to achieve I’m also open to that, this method is simply what I managed to think of so far.

Thank you all for your help,

Exploration 19 (structure 8).gh (17.4 KB)

Here are two screen caps to better explain the issue, maybe someone will be able to tell what’s wrong just by looking at these.

The first one is the full original mesh. The second one shows what happens after the 2nd mesh split component. I had at first combined the two splitting operations (XY planes and XZ planes) in a single mesh split component but was getting this issue so I tried having two mesh split components. The first one seems to be working fine, but not the second one.

At this point I’m probably going to try a looping approach using Anemone though I really feel I’m probably missing something super simple to make a more straightforward approach work.

Thanks for your help,

Hi @gduteaud,

sorry, I cannot test this because the server where Millipede is hosted is down. Do you know where I could download it?

Otherwise, can you please attach the meshes directly? Use a normal “Mesh param”, right click, and choose: “Internalize data”. Alternatively, you could bake the mesh and attach it here as a .3dm file.

There is no problem at all, and if you haven’t already, please have a look at this topic to get faster answers.



Giulio Piacentino
for Robert McNeel & Associates