Mayhem & Distortion — Rhino eating my model!


#1

So here I am building along and I decide to boolean unite a revolved shape with an extruded shape. Simple enough, I’ve done it a zillion times. Only now, I try to perform the basic operation and the results are catastrophic. The union distorts the rendering like it was smashed by a truck. This all started yesterday when I pulled a simple model off of GrabCad. I picked up a simple calliper adapter to add to my project. When I looked at the holes in the adapter, the were distorted. The lines that made up the interior walls of a basic tubular hole were broken and at odd lengths. So I extracted the inside surface and rebuilt a new wall. All was well. Today, I can’t seem to get anything to work.

Have a look at the attached images…


#2

Looks like the render mesh is all screwed up. Try changing the settings under render>Render properties>mesh set it to smooth and slower.


#3

Tried that. No change. So I try something else… I remove the extruded cylinder and extract the backside surface of the revolved shape. OK, now reattach the backside with the join function… just look at what happens!


(Pascal Golay) #4

Hi Ken - please try DivideAlongCreases on this object and also, run the CreaseSplitting command and make sure that is set to Yes,

Any better?

-Pascal


#5

This keeps getting more weird. So I undo the join function and now I use Join Edge. The function works… but look at the tolerance warning I’m getting…


(Chris Kuether ) #6

perhaps you mean dividealOngcreases …?


#7

How might I reset the tolerance and rendering settings? Perhaps the settings are baked.


(Pascal Golay) #9

Hi Ken - did you ever try DivideAlongCreases?

-Pascal