Major snafu with python/rhinoscriptsyntax and a Rhino freeze

Just had the weirdest thing happen…

I was typing something in the Python editor. It froze for 15-20 seconds while I was typing, then went back to normal. I finished what I was typing and then ran the couple of line scriptlet and got this error message:

Message: No module named rhinoscript.application

Traceback:
line 2, in , “C:\Users\Mitch\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\IronPython (814d908a-e25c-493d-97e9-ee3861957f49)\settings\lib\rhinoscriptsyntax.py”
line 1, in , “C:\Users\Mitch\AppData\Local\Temp\TempScript.py”

Odd, I then went and looked at that folder and there was indeed a rhinoscriptsyntax.py file and it did have from rhinoscript.application import * - so I went looking further.

Here’s where it gets weird:
In the settings\lib\rhinoscript folder, where all the individual files like application.py are stored, there was nothing at all!!! The folder was empty! 5 minutes earlier it had all the modules, I had checked.

Never seen that happen. So first thing I did was try a Repair on my Rhino install. It told me to restart my computer afterwards, which I did, but the missing files were not restored.

Finally I copied the missing files back into the directory from my other computer, and now it seems to be working again… Hope everything else is OK. I hesitated to uninstall and re-install, that was going to be my next step, but I was trying to avoid the hassle. I would have expected that Repair would restore those files though, I was surprised when it didn’t.

Anyway, I have no idea how/why that happened. Hopefully a one time gremlin.

I’ll go with that for now. < grin >

FWIW,

Because of the way things are, I’m often in a situation where I have to either Repair or Uninstall and re-install. I find the latter procedure to be a lot easier.