Linking an excel file to GH on MAC

I’m trying to link an excel file to a GH program used for pulling dimensions off of panels. The program was written for me on a PC, and I cannot get the GH program to find the excel file on my mac. Any help would be great.

20%20AM Hello-

Hi Stefan-

The path in your first screenshot only appears to point to a folder on the Desktop called GH_Files, not an actual Excel file. Perhaps there is some downstream logic that I can’t see in the screenshots.

Can you share the definition, perhaps we can find the problem? If you can’t share that definition, can you just share the portion that gets the Excel file path?

Thanks for getting back to me. Here are the files I’m working with. Its a program to make 32mm European style cabinet boxes. I’m trying to export the panel dimensions and labels to an excel file on a mac.

Any help would be terrific.

Have a great weekend.


(Attachment test-1.xlsx is missing) (5.11 KB)

Sample (142 KB)


Just got this message back when trying to send the excel file that I am trying to link. When I copy the path on my mac, it is only giving me that partial path, and I am inputing the /test-1 file name myself. I’m not sure how to get the whole path. See screen shot.


"Unfortunately some attachments in your email message to [“”] (titled Re: [McNeel Forum] [Grasshopper/GH for Mac] Linking an excel file to GH on MAC) were rejected.

test-1.xlsx: Sorry, the file you are trying to upload is not authorized (authorized extensions: dwg, dxf, zip, 7z, igs, stp, step, rhp, gh, gha, ghx, py, rvb, rui, txt, pdf, png, jpg, jpeg, gif, rmtl, renv, 3dm, rtex, ini, xml, mp4, stl, mov, macrhi, rar, ghpy, cs, cpp, svg, plist, skp, dgn, 3mf, rhi, dae, ghuser).

If you believe this is an error, contact a staff member."

The absolute path that points to the desktop on macOS looks for example like this:


The absolute path to you excel file should look like the following, if your file “test-1.xlsx” resides in the directory “GH_Files” on your “Desktop”.


Thanks. I made those changes to the file path, and am still getting the same result. Should this be working on mac without any additional plugins? I put ghexcel into my special components file, but haven’t verified that it is functioning.
Thx (5.11 KB)

You also need to put a trailing slash ("/") before “Volumes” and if your drive is called “Macintosh HD”, it needs to be called the same!
Have you tried setting the path via the File Path component available in vanilla Grasshopper? It lets you set the path by selecting the file from a system dialogue.
If the components aren’t working, you could try the Excel components from LunchBox. LunchBox works quite well on macOS.