Line perp from curve fails

why is this simple task failing ?
Line perp from curve,

  1. select curve, use ctrl osnap to get OnCurve
  2. click start of curve
  3. choose from first point
  4. drag line but it doesnt constarin perp !

see video

I am having to do this as the simple orient perp command for my triangular screw thread also refuses to head in that direction today, yet yesterday it worked a treat, as per the video I am following on screw threads.

why oh why does this happen.

see other post…


Hi Steve - hold Shift (ortho) - Perp can be anywhere in a ‘disc’ around the curve, Shift will find a lines that pay attention to the CPlane.


I can’t see what you’re doing.
Does this help? (470.0 KB)

I am with a curve that isnt a circle, (its plan view on a helix in fact) ,
I then do ctrl osnap and choose OnCrv
then I am picking the end of the curve and choosing ‘from last point’, by typing F and enter, else it doesnt know where on the curve to start the line from, and as such then as one can see it doesnt constrain perp, can go any angle.

I try the hold shift…pascal, it does stick out perp if one carefully moves mouse and finds the ‘sweet’ spot. but it doesnt allow me to move the end of the line shorter than an invisible minimum length barrier it presents.

file attached.
line perp to curve fail.3dm (56.6 KB)

note in video shift constrains but line wont go any shorter, will stretch longer but has a minimum limit on its length !

Notice also after I do the Ctrl osnap and pick the curve then it seems to relate to centre, yet I deliberately this time turned off centre osnap.


Dunno - worked here, four times

Top view:

Not sure what to suggest.

note that I have added that it does stick out perp, IN TOP VIEW NEED TO SEE THIS… but wont allow me to reduce line length.

a video of top view and my steps would prove some strange difference between my V5 and another.