Larger than, smaller than, equality function not working properly

Hi all,

I have a problem with the components described above in the title. For example,
whenever I have a list of numbers: 8, 6, 4, 2, 0 and I test whether or not it equal to 4, it will tell they are all false. Same thing for the smaller or larger than function. Whenever I check the booleans of “or equal to” it will say it is not equal. It is not a rounding error, nor do the tree branches not connect properly, and there are also no branches that are empty or invalid.

I have tried restarting rhino several times.

Any advice on how to fix this would be greatly appreciated!

Make sure the type of values you are checking are compatible. If you are inputting 4 from a panel (i.e. a string/text) and compare this to a integer value 4, then they will not be equal.

Thanks for your reply. I have an 8 from a slider, then adjusted with x/2 via expression at a number component. And the list I am checking, come from a list of points that I deconstruct into xyz and then test the x values. There are no panels in between connected. I have no idea why it is not working, it used to be working properly.

If you have any idea why it still wont work, please let me know :slight_smile:

A possibility: those numbers are floating point and probably include some tiny ‘fuzz’ and therefore equality might fail.

3. Attach minimal versions of all the relevant files

The file is rather rather big, but ill upload it anyways. The cluster that I am talking about is highlighted in green

[15 juni doet|attachment]

This is the largest list of missing plugins I’ve ever seen!


Apparently you didn’t read the paragraph I referred you to:

3. Attach minimal versions of all the relevant files
If you have a gh file you have a question about, attach it to the post. Do not expect that people will recreate a file based on a screen-shot because that’s a lot of pointless work. It’s also a good idea to remove everything non-essential from a gh file. You can use the Internalise Data menu option to cut everything to the left of a parameter:

Your cluster:

Your gh is a little too much to go through, with more plugins than I have ever seen (or have)

If you are checking the same types, then it probably is a rounding issue. Try rounding passing your values through an expression component with something like int(x*100)/100.

I know you said it wasnt a rounding issue, but even if it shows differently in a panel (because it is formatted), there could be more hidden fractions:

Or “round(x,3)”

1 Like

Hi guys,

Sorry for the big file, didnt know how to use internalise data, but now i do.

Also, there was only one plugin, Karamba3d, but for some reason all the components from that plugin were labelled as seperate plugins??

The rounding errors were indeed the problem, I have fixed it, thanks!