Isotrim rectangular surface with panels of specific dims

I’m trying to panelize a rectangular surface with 4’x8’ panels using isotrim. I keep getting the “1. Subsurface is invalid because the trimming U-domain is singular.” error. There are a lot of posts about it, but i still don’t know what it means or how to fix it. The surface’s location is being pulled in from another program, so it isn’t positioned at the origin.
Panelize.3dm (38.3 KB) (12.7 KB)

Is this what you’re looking for? Geometry is internalized, no need for Rhino file. (23.0 KB)

yes thank you, with the small exception that the “4” and “8” length inputs should be 48 and 96 to convert from feet to inches…but I’d also like the remaining space to be subdivided into partial panels that are cut from 4’x8’ panels, even though a full size sheet cannot fit.

Oh, that’s too bad. I don’t enjoy a wild goose chase (“moving the goal posts”). Easy to change ‘4’ to ‘48’ and ‘8’ to ‘96’ but partial panels? Off hand I don’t know, and have had my fun with this one.

Also, no good reason to do it this way except to demonstrate proficiency with data trees: (21.9 KB)

P.S. re: partial panels… got it to work by changing the expression slightly, from floor(x)+1 to floor(x)+2. But do you know why that works? Please be more careful describing issues. (23.3 KB)

1 Like

Thank you for your efforts
Why does floor(x)+2 work?

You will understand it better if you answer that for yourself.

The same changes I made to version ‘c’ can be made to version ‘a’.

1 Like

I tried to run this on another geometry instance and am getting the singular U-domain error. Is there something about the surface I’m creating that causes this? I noticed the brep item that isn’t causing this error is “untrimmed surface”, while the item that comes with error is “referenced brep”.
I created the surface with _PlanarSrf from closed curve (19.7 KB)

Your second ‘Brep’ is not internalized.

1 Like

Thanks, that was suggested on many posts for this particular error…If i right click the brep component and “internalise data”, I still get the error. When I draw the surface with the corner to corner tool instead, it all works fine. (24.2 KB)

Post the file with internalized geometry and the error. :roll_eyes:

1 Like

Mysterious. I’ve tried everything I know but don’t get it. When I create a rectangle of the same size and location, it works fine.

P.S. Aha :bangbang: I don’t know why or how to fix it but just discovered this, a negative value for ‘V min’ (V0):

1 Like

Can it be remapped? I won’t pretend to know what that means, but I’ve seen it in other posts, such as this one

Hah :bangbang: :rofl: I tried many things but am stumped.

I got something to work (yellow group) but have no idea why it happens. (28.5 KB)


it is working on all the surfaces that were not working previously, so thank you again!