Invalid curve after joining the curve

I separated three planes to calculate geometry for my mesh model. RS_0.5_1.5_FH.obj (15.5 KB)
But for XZ plane (the middle), one curve out of 12 curves become invalid.

I tried to explode and join the curve again but it seems doesn’t work.
Invalid (35.4 KB)

Instead of posting a separate file for the mesh, right click the Mesh component and click “Internalize”

I clicked and nothing happen…what is this button use for?

Instead of referencing geometry from a Rhino file and having to post two files (GH definition + input mesh) you can internalize the input and you only have to post one file. The person helping you can open the GH file and does not have to load any reference geometry.

PS: for these screenshots I haven’t referenced your mesh but the effect is the same.

Thank you for the advice! Is this file works now? Invalid (42.4 KB)

I still do not understand what you’re trying to achieve with this definition.

The mesh has self intersections which cause problems later on when you are trying to loft the section curves.

You can however tri remesh your bad mesh and turn it into a better mesh.

Lofting curves with such different control point structure is generally a bad idea without rebuilding.

The C# script to calculate the volume is obsolete but I left it.

General advice hower your mouse on inputs / outputs and you would for example see some information on path structure or if a Brep is closed or open…

Invalid (64.9 KB)