Increase subdivisions on SubD Surface

I’m playing around with a subD surface I created from a NURBS surface, but I have a dumb question: How do I increase the number of sub divisions? I had a density of UV from the NURBS surface I derived the subD from that I liked, but it looks like I’m stuck with what Rhino gives me. Thanks.

Hello - use the SubDivide command - does that do what you need?

-Pascal

Not quite. Since I posted I rebuilt my NURBS surface to include more UVs separately from increasing the density, which allowed the ToSubD command to respect the original surface. However, I’m finding that the sub divisions are not behaving as expected: Modifying the sub-object selection of a face behaves like a mesh and the continuous curvature is absent. Any ideas why this isn’t behaving correclty?

Hello - if that is a surface, it is degree 1 in U and V and should be, if I understand what you are after, which I may not, be 3 in each direction.

-Pascal

I’m pretty sure the original surface is degree 3. The result above is the subD which does not provide those options during the creation. What workflow respects the degree of a surface for subD?

Hello - I guess I do not have a good enough idea what you’re up to - can you post a file?

-Pascal

Sure thing. Some notes on my process that may shed light on the issue: I’m trying to create a SubD surface that I can use to model topography. I started by importing a mesh, extracting points, creating a patch surface, and then converting to SubD.
Site_Rhino_7.3dm (2.3 MB)

Hello - you might try QuadRemesh to go straight to SubD output from the mesh.

-Pascal

1 Like

That’s a great option. I’m still seeing the same problem with the resulting surface: no continuous curvature.

Cody, are you trying to exactly match a NURBS surface with a SubD surface? That is not always possible due to how the math works.

Make sure you ask for SubD output in the Quadremesh dialog.

-Pascal

Not exactly. I just want to SubD to behave properly when converted from some other type of surface to support modeling topography.

@pascal I did choose the SubD option from the quad remesh.

Hm - looks like this, here:

-Pascal

1 Like

Okay. I think I figured it out, and like I thought in the beginning, it was a really dumb question. I had the subD display toggle on, which displays everything “meshy.” Toggling this off displays the surfaces as expected. Nonetheless, all of the suggestions posted here were very helpful and I appreciate it.

1 Like