Importing SketchUp - any progress with texture mapping issues?

Saw a few earlier posts but nothing about whether texture scaling issues had been addressed when importing SketchUp files.



Twinmotion (FBX):

This may be a regression, can you post the example file and I can reopen the issue. Thanks

1 Like

Hi Japhy -thanks - here you go.

texture-test.skp (328.1 KB)

What version of Rhino are you running? Os and Build please. Thanks.

Windows 10

Rhino Version 7 SR15
(7.15.22039.13001, 2022-02-08)

1 Like

It would also help to see an image of the import settings you’re using.

1 Like

Hi Tim, Thanks for looking into this.

The settings i used to reproduce.

1 Like

Switch the face type from trimmed planes to mesh and see if it helps. When you use trimmed planes the object is meshed again when it gets shaded/rendered. I do use the TCs in the skp file to set the values in the m_S array but I honestly don’t know how/if those are used to generate TCs on the render mesh. If you use mesh to start with the TCs that are in the skp file are what is in the mesh.

The Texture mapping is working as expected on the mesh import.

I was using the setting recommended in Turner’s previous question.

1 Like

@Japhy @tim

A bit more experimenting… I have a test SketchUp file (attached):

When imported to Rhino first as trimmed planes (left) then as mesh (right), in Rendered view:

When view is switched to Raytraced:

And then switched back to Rendered:

So even though bringing it in as a mesh seems ok-ish, Rhino appears to lose mapping when the rendering method is changed.

SketchUp File:
uv-target-test.skp (245.8 KB)