I'm off in the weeds......again

I was trying to set a C plane. Somehow I’ve managed to rotate the top view port. How do I restore the views to normal?

UI may be different, but you can get it from this icon.
Coming back to the world coordiante top will get the default position back.

Toshiaki, the question was how to restore the viewport, not the CPlane. The answer is: from the menu View > Set View > Top. You can also start it by right-click on the viewport name in the left-top corner of the viewport.


1 Like

Woops… my bad…
I’ll be more careful next time.

Set View > Top as Maxz indicates.

Familiarize yourself with these commands:

Then advance to these, to which you will apply setview to as well:

1 Like

you probably did that by command-shift or alt-shift in case you want to know how it happened.
just use 4View it will reset all back to normal.

i guess that does not matter much for the OP, since the result Toshi pointed towards will be the same :wink:

I have to disagree Richard. In Top view, when I change the CP (not all changes, you will have to get it really out of whack, for instance by changing the local z-axis to something not parallel to the world z-axis), then right-click&drag, the viewport starts turning instead of panning. Resetting the CP to world top as Toshiaki suggested will not stop that, you will have to go trough the motions that I described to get it back to normal.


i dont know how out of whack you mean but i tried now really hard to screw it up rotating, moving the cplane and rotating the view. but _CPlane World Top resets both view and cplane back to origin in the top view. can you post such a messed up cplane in a file?

OK, here is one. In Top view, I changed the CPlane with CPlane and set the Z-axis across the 3D-diagonal of the cube. The Top view can now be “rotated” (actually the camera/viewpoint rotates) by dragging with right-click pressed. Normally that would pan the view.
testing.3dm (2.5 MB)


nope, that does not hold the regular Cplane command off from setting things right. below a video, i just used a macro and the macro editor to show it faster but regular cplane with world top would do.

Strange that Richard, mine works definitely different. I tried several ways to invoke the command, even mimicked the same macro that you used by copying and pasting _CPlane World Top and entering, but all gave the same result. I am using version 5.3.2.


have you got a wip accessible and try there? i use 5.4 and have no regular version around to compare i am kinda in greed for the new options and wips are pretty stable i must say.

I downloaded and installed 5.4 WIP, tried again but still the same. FWIW here are my view settings:

The ticked boxes down on the left say that setting a named view will also set the CPlane, but you are experiencing the reverse, and I am not. Strange.

hehe, well than either you have a bug or i do, since i experienced some issue with not being able to undo unrolled surface with dots after clicking them and being the only one, it could be that there are still other issues, but i reset my settings and everything else works now. idk. @Toshiaki_Takano how does it work in yours? does it reset the view with the cplane?

Hi @RichardZ

Hmm, actually what I replied before with the Cplane only resets the cplane and not the view. I’ve tried with latest WIP.

To get the top view, I still needed the setview.


_setview _world _top