I'm having problems splitting a polysurface with a surface. [removed duplicate words]

It keeps saying “Split failed, objects may not intersect or intersections may not split object.” What can I do to fix this? File is below, any help would be appreciated!

Canopy and Wishbone.3dm (949.3 KB)

Hello - this is Rhino’s intersector not getting the full curves of intersection - Run Intersect on the bigger flat surfaces and one of the vertical elements to see what I mean.
You can InsertKnot in U on the flattish surfaces with the Automatic option a couple of times to ‘densify’ it a bit and the intersector likes that better. Thanks for the example.



Hi Pascal, thanks for the quick response. I ran Intersect and I can see that the curves aren’t complete, I also ran InsertKnot, or at least I believe I ran it. Not sure how it works, but after a couple times of doing it I still kept getting the same failed message.

OK, I’ll take a closer look - I kind of looked ‘on the run’ earlier and found that one thing but there may be more.
@ramarz23 - try this:

RemoveMultiKnot from the two half-ellipses.
DupEdge the three edges that make the shape:

Loft, with ‘Straight sections’ the three curves:

Use that to trim.

How did you make your surfaces? Can you post the curves that made them?


@pascal I actually ended up deleting those 2 separate surfaces, making one big oval, rebuilt it with more points. Turned the points on and then manipulated it into the “dome” shape. This gave me a cleaner surface and was actually able to cut through the shapes. But now reading your solution I tried it that way as well and voila it worked great too! Thank you so much!!!