How to set GPU as default render device?

gpurender
unhandled

#1

Each time i open a 3dm file I have to manually set my GTX 950 as the render device. How can I make this default? I do not have the plugin installed only std rhino cycles view-port raytraycing

  • Roy Berntsen

(Nathan 'jesterKing' Letwory) #2

If you have only one GPU (CUDA) it should be selected by default.

If RhinoCycles_SelectDevice with -1 as input doesn’t give you that then I must have typed a bug somewhere :open_mouth:

Could you please post the output of the commands: RhinoCycles_ListDevices and RhinoCycles_SelectDevice (with -1 as input).

That said, I do have plug-in settings still on my list to do. There’ll be eventually a section in view properties that will allow you to set the render device (including multi-device setting, i.e. select two GPUs to render together).

/Nathan


#4

It gives me -1 as default, I thought -1 was the CPU… It seems to me that the GPU is 1

Command: RhinoCycles_ListDevices
We have 2 devices

Device 0: CPU > Intel Core i7-4720HQ CPU @ 2.60GHz > 0 | False | True | False | CPU
Device 1: CUDA_GeForce GTX 950M_0000:01:00 > GeForce GTX 950M > 0 | False | True | False | CUDA

Command: RhinoCycles_SelectDevice
User selected device -1: ccl.Device: GeForce GTX 950M (CUDA), Id 1 Num 0 Name CUDA_GeForce GTX 950M_0000:01:00 DisplayDevice False AdvancedShading True PackImages False


(Nathan 'jesterKing' Letwory) #5

-1 picks GPU (CUDA) by default, or CPU if no CUDA GPU was found. In the future, when OpenCL is stable enough -1 will pick the first GPU device found in the list (including AMD GPUs).


#6

HI all,

Is it possible to select multiple GPU’s during rendering in RhinoCycles_SelectDevice? I’ve selected my 1080 but I would like to utilize my Quadro as well.

When I do a raytrace rendering (Not selecting render) they both work. When I render,only one is working at a 10-20 percent.

Thank you

Stelios


(Nathan 'jesterKing' Letwory) #7

You can make a multi-device through Tools > Options > Cycles. Just make the multiple selection under CUDA.

I’ll have to check next week. I probably can set up my machine with a second CUDA card to test.


#8

I have difficulties to use my GPU as render devices, I installed Cycles PlugIn and the Radeon render plugin, I tried the “RhinoCycles_SelectDevice” :

"Select device to render on (-1 for default, 0-1) <-1>: -1
User selected device -1: ccl.Device: GeForce GTX 1080 Ti (CUDA), Id 1 Num 0 Name CUDA_GeForce GTX 1080 Ti_0000:02:00 DisplayDevice False AdvancedShading True "

I have set GTX 1080 selected as Cuda device in the RhinoOptions/ Cycles preferences.

However everytime I render the CPU usage goes 100% and the GPU usage stay under 5%

To confirm, The GPU rendering on Blender does work.

There is probably a basic option to select somewhere that I missed, but I just can’t figure which one.

Any helps ?


(Nathan 'jesterKing' Letwory) #9

For Rhino 6 don’t use the Cycles plug-in (Cycles for Rhino). Instead just switch a view to Raytraced. If you need to get images rendered at different resolution than the viewport you can use the _ViewCaptureToClipboard and _ViewCaptureToFile commands.

If you’re trying to use the ProRender viewport mode, then I don’t think you’ll be able to chose the Nvidia GPU, since that card isn’t certified for ProRender. You can try _ProRenderSelectDevice though.

/Nathan


#11

Hi Nathan. With the advent of eGPUs and other powerful external GPUs, does Rhino / can Rhino take advantage of these, either as primary or additional? Thanx.


(jesterKing) #12

If the GPU shows up in the device list Cycles can use it. I haven’t used these devices, so I don’t have experience with these. I think that @Toshiaki_Takano has such a device.


#13

I’ve got a GTX1070 as thunderbolt eGPU
from Gigabyte.
Can clearly feel the power.

One thing was not sure if my Dell XPS15’s thunderbolt was as fast as it can be as it also has onboard GTX1050 and that might be taking up a physical channel.
Bandwidth on thunderbolt is something that may need to be checked for max performance.

Tho I don’t have a desktop so I’m happy with it.