How to resolve timeout error with Compute?

Hi, We have create grasshopper workflow which infills lattice inside geometries. For smaller files it is working fine but for larger files we are getting following error. What needs to change here ? we are calling our grasshopper endpoint from nodeJs.

thanks in advance

You can change the timeout value by setting an environment variable called RHINO_COMPUTE_TIMEOUT whose value represents the number of seconds you want to wait (the default is 100 seconds). See this thread.

Hey Andy,
I tried this solution by changing the value of Environment variable on my ec2 machine. but still it had not resolved the timeout issue. Is there anything else we need to change because I was recording the time intervals of exception it is occurring after 100seconds only. I had restarted the machine also still it is same

It could be the timeout in your client-side HTTP client. If you’re using Hops, this can be configured in the Hops preferences (go to Grasshopper → Preferences → Solver). If you’re creating your own solution (for a website for example), then you’ll need to configure the timeout for whatever HTTP client you’re using.

I have configure my nodeJs script and added a timeout property but I am getting this error now

This look like the connection between your client and Rhino.Compute is broken. My guess is that whatever change was made has effected this connection.