How to deselect in Rhino 6

Been using Rhino for a few years now and always deselected from selected objects/curves by pressing the CTRL + Click command but recently it all that shows up is a small menu box. Tried to find the command in aliases/keyboard commands in options but was not able to find anything. Feel like I’m missing something.

In Rhino for Mac, deselecting individual objects from a selection of objects is done by SHIFT + CMD +LMB (left mouse button) clicking on the desired objects.
If I remember correctly, the shortcut should be SHIFT + CTRL + LMB on Windows?

Normal objects or subobjects?

For normal objects, adding to selection is done with Shift+LMB, removing from selection is done with Ctrl+LMB (Windows) or Cmd+LMB (Mac).

For subobjects, selection is done with Shift+Ctrl+LMB (Windows) or Shift+Cmd+LMB (Mac).

To deselect already selected subobjects, a second Shift+Ctrl+LMB (Windows) or Shift+Cmd+LMB (Mac) on the same subobject will deselect it.

Yes, I have tried that as well. I have checked all the forums and they all say the same thing which makes me question if this is a bug fix or I specifically have an isolated issue. I restored the default commands and still the same menu pop up window shows up. Is there a title for this command so I can give it a new alias? Any alternatives or theories are appreciated

Does this also happen if you start Rhino in safe mode? Installed any plug-ins or something else that might affect selection? Any other programs running in the background? Restarted the computer?

It ended up being a plug in issue in the end. thanks!

It’s good to document here which plugin caused this


Please let me know what plugin in causing this. i have this issue as well

Hi - that turned out to be a Mac/Parallels/gamer keyboard issue.
Could you please run the Rhino SystemInfo command and post the result here?