Honeybee external daylight analysis error

python
(Eifionworth) #1

I have recently started using grasshopper and I’m trying to analyse the daylight available on an existing site using the honeybee for grasshopper plugin. I have modelled topography and trees as simplified shapes based upon a 3D scan I did of the site. I would like to analyse what level of illuminance is available on the exisiting site with the aim of creating a 3D geometry which represents a certain level of daylight e.g a zone which always receives 1000 lux or more. A youtube video showing 3D daylight factor analysis is shown here: https://www.youtube.com/watch?v=-Fb0FBF9NdQ Ideally I would eventually like to develop a similar tool to this for illuminace values.

I have attempted to do an external daylight analysis by using the example file on this web page: http://hydrashare.github.io/hydra/viewer?owner=mostaphaRoudsari&fork=hydra_1&id=Honeybee_Grid-based_Daylight_Simulation_Example_II&slide=0&scale=1&offset=0,0 I have imported my rhino geometry into grasshopper and created a 3D analysis point grid however when running the simulation the following error message from the run daylight simulation icon appears: invalid literal for int () with base 10: 'a’

Having researched this error message online it could possibly be an issue with python? I have already successfully ran a basic sunlight analysis of my site using ladybug so I don’t think that my site geometry is the problem. Any help on how to get the daylight analysis to run successfully would be really appreciated.

Grasshopper files with internalised data are attached.

Site Daylight Test.gh (8.3 MB)
Site Sunlight Hours Test.gh (8.2 MB)

Many thanks,

Eifion

0 Likes

(Graham) #2

Yes looks like it has received some text (letter a or a word beginning with a) where it was expecting an integer number or a list of numbers.
Have you entered values somewhere in your definition? Have you used a text file (eg csv) as input? Could it be a problem with the decimal separator on your machine (point or comma) ?

0 Likes

(Eifionworth) #3

Many thanks for your feedback Graham. I’ve tried running the grasshopper definition on another computer and the same error message appears so I guess that it must be something to do with the input .epw weather file. I’ll try looking into it further.

0 Likes

#4

There’s a dedicated forum for honeybee/ladybug etc. You will get much better, relevant support over there
https://discourse.ladybug.tools

0 Likes

(Eifionworth) #5

Thank you, I’ll have a look there.

0 Likes