Hit a snag with Rhino 6 level 2 training material

Can someone clarify why I’m seeing… or rather not seeing an object in Rhino where there clearly is one (an error)? It is solid on the bottom of my mouse I’m drawing up as part of Rhino 6 level 2 training material stuff. Now, I have it set to View, Shaded. And while the rest can be seen green (default color I set as green for objects in Rhino 6), the bottom cannot be seen… but I tested it out and it is surely there even though invisible. I did not set anything to hidden (even on accident, even checked that)… so why is it looking like this? A Rhino version 6 error??

Trackball12.3dm (1.7 MB) <the file says ‘closed solid polysurface’ for my mouse, yet the bottom is invisible… why?

ShrinkTrimmedSrf seems to have caused the issue… but why? It sealed up the front of my mouse, but then made the bottom disappear… but only visually disappear on me, not actually deleted/gone away. Can anyone help? Has anyone had a similar problem with this command before?

Diego, how did you split it up and get it to show that other planar surface on the right side in your picture (for the upper bottom flat surface)? That was the one that went invisible on me. Was it the explode command or that plug in that does that?

Good morning. ya, plug in here: https://www.food4rhino.com/app/eve-explode called EVE Explode. OK, I get it, you really then had to rebuild edges in order to see that 2nd bottom surface. Well, let me ask you a simple question: when I create 1 surface (using the ‘patch’ tool) that’s a bit loose and undefined (from the curves it was based upon) and a 2nd surface (using the 2 rail sweep tool) next to it that is well defined and with it’s edges exactly up against/next to the curves it was created from… then what is or are the proper tool(s) to use to fill in any gaps that will be there? I’m guessing 2, one called Blend and the other tool (I use the menu however) called ‘join 2 edges’. These all (whatever those best tools to use are) would be surface tools under the surface tab, right?

BlendSrf creates a new surface connecting two surfaces. Don’t use it to fix a problem with surface edges not quite close enough to each other. Creating skinny surfaces to fill gaps usually results in other problems.

MatchSrf will try to pull the edge of one surface to the edge of another surface, or pull both edges to their average location.

JoinEdges essentially has Rhino treat two surface edges which don’t coincide as if they did. It can be useful in some situations such as calculating a volume when the model has naked edges, but in general it should be avoided.


just tried it; just tried MatchSrf command/tool and hit another snag: “Surface being changed can’t be part of a polysurface” (the top surface is a regular surface and the middle surface is considered a polysurface) …like, is there a way to change a polysurface to be technically considered a normal/regular surface in the object properties window?

OK, smart ass, I read the F1 page, but fully understand now that MatchSrf command/tool must be used only on an untrimmed edge. What I have with my mouse is a trimmed edge since I used the ‘patch’ command to make that top part (the thing that looks like a turtle shell). So, what command/tool should I use for trimmed edges or trimmed surfaces to fill or bridge the gap? I noticed when it is VERY close, that often ‘join 2 edges’ works. Other than that, only the Blend tool works well enough. But, I have hit another dead end with the blend tool since it created edges on the ends of my seam surface that don’t match up with any other edges nearby… so cannot join it to anything to create a closed solid polysurface. Have any ideas?

Wait, I got an idea… where’s the tool to extract a new curve… something like, ‘extract edge curves’ or something similar? Then, I could have a proper curve to match up the middle surface (created by sweep 2 rail command) to the top surface that looks like a turtle shell.

yes, tried that… helps a bit… but does not show IF someone chooses to use that ‘patch’ command instead of loft or what have you for the top turtle shell part of the mouse


MatchSrf needs an untrimmed edge of a surface to be modified, but it can match to a trimmed edge.

I assume “Join 2 edges” is JoinEdge which as I mentioned above should be avoided.

Patch is very useful but it has some significant limitations as you are discovering. If possible a new surface should be created without using Patch.

You might try extending the surfaces using ExtendSrf so that they intersect, and then trim the surfaces with each other. If the intersection of the surfaces does not extend from edge to edge of both surfaces and is not a closed loop then Intersect the surfaces then ExtendCrvOnSrf the resulting intersection curve so that it extends to the edges of the surface, and use the extended curve to trim the surface.

1 Like

yay! It worked. DupEdge command worked to solve my issue/snag (but still an obvious error with that shrink tool). I could have used this command on my space craft’s exterior had I known about it earlier… but will have to redo the exterior in order to use that now and not sure I want to since certain things on the inside are now aligned perfectly. Will probably throw off alignment if any change in my exterior surfaces are made, but will keep this in mind for the future. I’m sure It’ll come in handy as it fixes the fitting issue between different surfaces that need to be tied together. I like using patch because it allows me to be a bit lazy and just have a few curves thrown out there and wahla! Magic! Magically smooths it out for me with pop up window setting tweeked. Problem using ExtendSrf is that it will extend it out without any blending and corners will be abrupt/sharp… which may or may not suit my design style, but will keep that in mind along with surface trimming. Thanks David. B.T.W. I had found that YouTube video just before my post “Hit a snag…” here Diego so yes, VERY useful. And, that “Join 2 edges” I was talking about is that menu item under Analyze>Edge Tools>Join 2 Naked Edges (same thing, yes)Trackball15.3dm (417.2 KB)

also, a note, that by doing it this way I noticed I couldn’t use that solid tool called ‘cap planar holes’ but whatever cuz I still could use that ‘Surface from 2, 3, or 4 edge curves’ tool instead which did work

Why did this problem happen in the 1st place, where this curve was not flat? …damn, and I’ve been suspecting a hacker on my PC from your competition ViaCAD Pro… is that possible? Their customer tech support service has admitted to diving into my PC’s files and file system to see specific files and file structures to ‘make sure everything’s alright’ LOL… A trust issue? Fingers crossed on plugin programmers not hacking my PC either… I know when I had the trial version of FormZ Pro, I was hacked either by them or one of my Windows Store APPS for sure. Mouse cursor literally moved on me without me doing anything (and my mouse never does that crazy stuff before or since)! But is it likely that Rhino3D is doing something itself to not align a mirrored or ‘symmetry’ kind of curve? …I think I might have used that symmetry command, so could that have messed it up and made my bottom curve less than perfectly flat?

tiny chance… very tiny, yes

uh oh… I just hit another snag; this time that invisible error is happening again only on my Perspective viewport… don’t tell me it’s my WIN 10 or AMD video card or drivers issue, LOL… but, yes I did pretty much what you did to correct that curve at the bottom and redo 2 rail sweep and then that CAP PLANAR HOLES tool worked for me, good but now I’m left wondering about why it’s going invisible on me in a different situation but in the same ‘Perspective’ viewport… uh, man…

do you, or anyone else see this same invisible error on your end? And if so, are you also using Rhino 6, Windows 10 with use of an AMD Radeon RX 580 video/graphics card?Trackball16.3dm (535.7 KB)

if I have the dirty curve, then how did I get that ‘cap planar holes’ command to work for me just now?

Explode the model or ExtractSrf (with Copy=No) the planar surface.
DupBorder the planar surface.
Untrim the planar surface. It should now be opaque in shaded or rendered display mode.
Trim the planar surface with the curve from DupBorder. It should still be opaque.

Based on the above it appears the problem is the input in creating the planar surface Exactly how did you create the planar surface?

And a side-effect is very complex trim curves which may cause problems with further modeling. The long term solution is to learn to model without relying on Patch.

I use Patch but in a different way. First create a surface with clean, simple edges which match other geometry, and then use that surface as a starting surface in Patch. Usually a couple of iterations are needed.

1 Like