History broken when working between R5 and R8

I have R8 but I frequently save files as R5 so a colleague can work with me on them. This has been working fine for the last few months but this week when he opens the R5 files, in R5, the history on and swept or lofted surfaces is gone. The history on curves remains. When I re-open the R5 file in R8 there is no problem.

Hi Meg - so to reproduce, loft with History, save to V5, open the file in V5 and the history is not respected. correct?
I see this. @Meg_Walker - had you just updated V8 when you noticed this?


yeah - the curves still have history but the surfaces don’t follow. same with swept surfaces

I updated a few weeks ago and it’s been working until now

Hi Meg - if it is something that changed in V8, there is a chance we can fix it. I’ll try to figure out what build broke it…



any news?

Hi is there any update on this?

I’ev spoken to my colleague on R5 and he is getting “error reading archive” now when he opens anything which I’ve had open on R8. History is still broken on any lofted or swept surfaces. Have tried turning off VRay plugin before I save it, not saving textures, not haveing anything closed or locked, exporting the model and him importing it into a new R5 file. All the same result. At this point I may need to revert back to an old version which works with R5 or I can’t continue working.

Hi Meg - All I can tell you so far is that as far as I can see both V7 and V8 saved to V5 does not properly update history in V5. Since it fails from V7 as well as 8, it seems unlikely that a change in V8 caused it. If you know for certain there is a version of 8 that allowed this to work, please let me know - I’ll see if I can find one in the meantime.

I could not make this work in any Rhino’s after V6.
RH-81971 Saving history to V5 glitch

@Meg_Walker - a developer confirms that the way Loft uses History was changed in 2019 and is no longer compatible with V5. There is no version of Rhino in which this would have worked after that.


thanks for looking into this. I’m back on Rhino 6

also: I’ve spoken again with my coleague on R5 and he says that “maybe” he’s not actually tried to alter and lofted surfaces on the models I’ve sent since I updated to R8 (I was under the impression he had), so please don’t spend further time digging as I think you’ve found the answer.