Help! -Trim/Cut object with another object

Cannot seem to trim/cut 1 object with another. The result I’m looking for is 2 separate objects where one can be NESTED on to the other after 3d printing them separately. I am casting each object in different materials, then soldering together.
Very important operation for me to get a workflow for as I need to do this a lot. Hope someone out there can help me out. I’ve unsuccessfully gone through multiple tutorials that have not helped.
Attached sample images of what I’m trying to do.

Clayoo won’t do that.

You need to convert the objects to NURBs polysurfaces and do a boolean subtraction.

Thanks for your quick reply!! So do all that in Rhino then?

Yup. Also, get the Rhino 7 WIP and start learning Rhino native SubD. There are a few things that Clayoo can do that it can’t (multi-gumball is the most noticeable one), but there are many more things that Rhino native subD can do that Clayoo can’t.

Thanks very much for you’re tips!

1 Like

Booleandifference is getting me on track! But how can I clean up the resulting object to eliminate the areas to be deleted? Your help would be much appreciated, I’m so close!
Attached resulting object pics

Hmmm. First thing I see is that I think you did your conversion to nurbs while you were in faceted display mode in Clayoo. Switch to smooth mode before the conversion.

As for the results, I think you might just need to lift the fish up a tiny bit. Also make sure you’re hiding your clayoo objects after you convert to nurbs.

Hi @SitkaDude,

You can also try with MeshBooleanDifference with Clayoo objects instead of converting objects to NURBS.


I’m working with my real project objects now and as you can see the whale object has white mesh lines as compared to the bezels black mesh lines. Mesh Boolean Difference does not seem to work with. You can see result in last pic. Any ideas how I can get the whale to same format as the bezel?

Hope I can get straightened on this, starting to drive me crazy…

Probably lines colors are different because they’re on different layer or set individually to those objects.
If MeshBoolean doesn’t work try the other approach to convert to Nurbs and then do a Boolean difference with the results.


Different layers it was. Could not do the Mesh Boolean when they were different layers. Merged into one layer and Viola, it worked!!
Thanks so much, think I’m on my way now!
Soon I will be wanting to try to “Drape” over objects/meshes that have a lot of internal geometry and rigging so I can convert into a closed surface mesh (perhaps creating a solid) to work with. Hope I might be able to ask you about this if I run into stumbling blocks when I start doing this down the road.
Thank you,