Help! File Processing Speed is So Slow

Hi, I’ve been trying to create a grasshopper file that would build my wall system for my current project, so that I don’t have to build it over and over again, as it is so time-consuming. However, I have run into a couple of snags. The biggest one being that the file is running extremely slow. I’m fairly new to grasshopper and am not sure if the slowness is on my part or if that is just how it is. Any help would be greatly appreciated in solving this problem. (34.7 KB)
WallSystem2.3dm (3.5 MB)

uff, yeah the patch and extrusion combo is really taking a while. I don’t have anything off hand to make that geometry in a fast way.

One thing you can do is disable all the instances of patch / extrusion to be able to work quickly before turning all on when needed. My machine was taking about a minute to calculate.

Thanks for your response, yeah trying to figure out if there is any way to reorganize the process to speed it up.

if you can get rid of the patch components you’ll be off to the races.

It seems you are using a pretty old version of the offset surface components. I actually have a different Offset Surface component that someone on the forum once gave me. It is MUCH faster.

Here is your patch before (using MetaHopper’s Bottleneck Navigator):

Here you can see the difference between the 2 components:

I would also recommend that you disable the preview of everything except the stuff you need like that one geometry node at the end. Otherwise on top of calculating every component it also creates a mesh for every component, which also makes the viewport very slow. (44.6 KB)

1 Like

Hi, I tried this and it is working much faster, however, the geometry is growing outside of the bounds of the curves. It is not functioning like a loft or sweep, it’s creating a strange geometry, any idea what might cause this?

Yeah, I saw there was some weirdness in some cases. In one case I changed some parameters in the Patch components and then it worked fine. So it’s probably something similar.

Yes, found it very quickly. It was the spans on the patch component. if you increase the number, it works fine.


after (46.8 KB)