Grid slowing down display


(Willem Derks) #1

Hi,

I received a Rhino file from a client, it was painfully slow in display speed and I had no idea why.
Until I realized the grid was set to 50000; setting that number back to 500 made the display seamless again.

I wanted to report it here as I’m sure the client is not aware of the impact such a simple setting as the grid extends can have.

-Willem


(Brian James) #2

Hi Willem,

I’m not able to create the pain here setting a grid to 50,000 lines. Any chance you can send a version of the file to tech with all confidential objects deleted but still showing the issue? My first thought was that the AA setting might be involved too but I’m using that here without the slow down you reported.


(Willem Derks) #3

Hi Brian,

Open this file:slow viewmanipulation.3dm (27.2 KB)

Try turning the view, next set the gridline number back to 100. I note a significant difference.

Thanks
-Willem


(Brian James) #4

Thanks Willem. I’m not sure what can be done about this although I can see a difference now too. How zoomed in you are and the AA setting all play a part so it’s great to have the test case to open for consistent testing. I filed this as RH-23269 for development to look into for future reference.