Grasshopper Plugins not loading in RiR but they do in Rhino 6

Hi, when I run Grasshopper within RiR, I’m missing my plugins. However, when I run Grasshopper with Rhino 6, it doesn’t have this issue. The plugins all load into the document. Why might this be the case?

The plugins that I have installed are Human, Elefront, and FalseStartToggle.

So Rhino.Inside.Revit works with Rhino WIP which is technically Rhino 7 in progress. Check under %APPDATA\Grasshopper path on your machine and make sure the GH addons are installed under %APPDATA\Grasshopper\Libraries\ and not the %APPDATA\Grasshopper\6\Libraries

I have these addons installed and they work

They are indeed in that folder rather than the /6/ folder. I’m actually trying to do this on a colleague’s machine. It’s not working there though it does work on mine using the folder structure you suggested. That is why I’m so confused.

1 Like

If you start Rhino 7 WIP by itself, without Revit running, do all the plugins load in Grasshopper?

1 Like

I got it to work using this folder structure suggested in this topic:

Not sure if this is the best solution but I’ll take it for now.

I have the same problem and it loads fine with just Rhino 7

The previous workaround mentioned worked for me but there are still a lot of conflicts with my initial library and the one I created, this means in my case conflicts with C:\Users\YOURNAME\AppData\Roaming\Grasshopper\Libraries and C:\ProgramData\Grasshopper\Libraries-Inside-Revit-2021
Could we get more input from the company ? SHould we submit a request ?