Grasshopper minimal surface

hi, i made minimal surface using minimal surface comp

I made 2 minimal surfaces, i need first one

I do not want the hole in it to be blocked
How is that possible?

There are big chances that it is not minimal surface !
There is no minimal surface if the 2 curves could be contained in 2 90° cone.

I looked at the minimal surface component. It seems to not release minimal surfaces in some cases. When I use Mesh Relax on a pseudo minimal surface the shape changes also if you look at mean curvature this one is not equal to 0.
So try to me more clear on what you want but don’t expect to have true minimal surface with the spacing of your circles.

1 Like

the whole talk about minimal surfaces is pseudo.:no_mouth: The moment you move away from the mathematical base shapes you won’t keep mean curvature close to 0. And even if you stay with the regular shapes but trying to get a NURBs approximation, you already move away from this with greater deviation.
So in the end its a pseudo technical buzzword. It might be a better idea to learn basics about smooth surface modelling, knowing more about blending and filleting shapes, in conjunction with the right analysis (f.e. curvature analysis) to test for your technical needs. Mesh relaxation or Sub-d for a simplified shape representation is an alternative, but its not truly minimal, so why not modelling it the way you like applying modelling principles to come close. This will give much more freedom on design. :slightly_smiling_face:


Very strong argument there :slight_smile: Way better and way more practical in reality is to aim for a shape in force equilibrium. Especially if you need your surface to be able to carry any external loads. Zero curvatere means zero load carrying at that specific point.

1 Like

Firstly, the surface, as explained above is not a “minimal surface” it is a mathematical approximation.

To clarify, Minimal surfaces are those with “uniform stresses” all over the mesh. (hence the “necking” at the center)

IF you don’t want the necking to occur, you will have say double the stresses in the longer direction than the transverse direction, and hence no uniform stress anymore.

There are plugins such as rhinomembrane that will allow you to achieve such results, as they are based on FDM - force density method or the Update reference strategy method.

Then again, you can reduce the distance between the ellipses, and you should get a better form …

So how to keep the two curves from twisting cones?

Regardless of distance, it seems that there is a fundamental problem when looking at lofted surfaces
0522.3dm (367.8 KB)

Thnks for comp

i checked it works,

but i dont know why it cant make when applied to a curve

it seems that there is a fundamental problem when looking at lofted surfaces
how do you think?
Minimal Surface (10.3 KB)
bullantrhinov5v1306.rar (2.2 MB)

When I look at the picture that I attached, the lofted surface seems to have a fundamental problem, regardless of the distance

Do you think whats problem?

Its not the (loft) algorithm, its the way how you use it. Usually, when using “Loft” you need to ensure that the seam is correct. Furthermore curves should be parameterised equally. best: same cp-count, degree, direction etc.

However, the “Loft” command has a certain importance to create developable surfaces in ship building. Its furthermore heavily “misused” in Grasshopper to create quick surfaces. :roll_eyes:
However the Loft command is a very bad command in general surface modelling, because it creates way to many control points, which results in a lot of problems later on.

Most problems in the Grasshopper section are due to a lack of understanding freeform surface modelling and it doesn’t make sense to help someone on such a complex topic who misses basic knowledge. So my advise is, model it manually. This particular shape can modelled in less then 1 minute. I guess it should become more complex later on, so for someone inexperienced a good alternative is using Sub-D’s instead. But don’t do this in GH unless you really know about what you are doing. You can also use Kangaroo or others for relaxation, but again you don’t have any true control on your shape.

1 Like

Agree with what @TomTom said. But to fix what is in your screenshot the issue is a very basic one. Your seams do not align. Grasshopper has a change seam component. Rhino has a crvseam command.


If you are feeling particularly lazy you can give the loft components align sections or adjust seams options a try.

After that you may still have to flip the direction of the curves as well either with grasshoppers flip curve component or Rhino’s flip command.

In short, you wont need to do any of this if you draw the curves correctly in the first place. It is important to pay attention to the direction in which you draw a curve and the start/end point as lofts and most interpolation tools will blindly follow these locations and flows.

1 Like

Thanks for advice Pryor

rebuild crv and adj loft option, it succeeded in making the loft side.

I agree with tom’s opinion that making faces directly is fast.
But that curves are parts of my work and I needed specific curves to make faces.

I have found that problems can arise because the curves were created through mirrored operations

I flipped one curve and got a similar result what i want.
How can i change the connection of the lines like a black line?

Are the lines connected by the green line the optimal state where the points at the nearest distance are connected?

0523.3dm (161.0 KB)
0523 (34.3 KB)

How can i change the connection of the lines like a black line?

Adjust / align the curve seams.

Thanks for the quick answer