Grasshopper is slow

Hi all,

With grasshopper 1.0, computation is very slow and caching geometry is just a horror !

The difference is obvious with gh 0.9 (rh5)

Why ?

You probably want to attach a definition that illustrates the problem.

It would be good to attach the result of the Rhino 6 command _SystemInfo.

I can’t share a file, but just selecting the same items with gh 0.9(rhino 5) or gh 1.0 (rhino 6) doesn’t take the same time !

For my _SystemeInfo with rh6
Rhino 6 SR6 2018-6-26 (Rhino 6, 6.6.18177.16151, Git hash:master @ abeff9e9af62a0e02a9eb52efa77e179a682f2c7)
Licence type: Commerciale, version 2018-06-26
License details: Cloud Zoo. In use by: Blanc Aurelien (aurblanc)

Windows 7 SP1 (Physical RAM: 32Gb)
Machine name: HP-Z420

GeForce GTX 780/PCIe/SSE2 (OpenGL ver:4.5.0 NVIDIA 352.86)

OpenGL Settings
  Safe mode: Off
  Use accelerated hardware modes: On
  Redraw scene when viewports are exposed: On
  Anti-alias mode: 4x
  Mip Map Filtering: Linear
  Anisotropic Filtering Mode: Height
  Vendor Name: NVIDIA Corporation
  Render version: 4.5
  Shading Language: 4.50 NVIDIA
  Driver Date: 5-11-2015
  Driver Version:
  Maximum Texture size: 16384 x 16384
  Z-Buffer depth: 24 bits
  Maximum Viewport size: 16384 x 16384
  Total Video Memory: 3 GB

You might want to try updating your GPU driver. There might be some speed improvements to be had with a recent driver for your GTX 780.

Okay, I’ll try that. Thanks for your time.
for your information the time difference is the same on other more recent PC

It’ll be hard to tell what the reason is without a way to reproduce.

If you have third-party plug-ins installed you could try disabling them, restart Rhino, then see if there is any improvement. If not, then really, a file that reproduces your problem would be very useful.