Grasshopper Graphics (un-baked) on external GPU

unhandled
gpu

#1

We’re trying out external GPUs in our office (Nvidia 1080 GTX founders edition inside an Akitio Node connected via Thunderbolt 3 to a mid-level Latitude notebook with integrated graphics). Our hope was that this setup would allow us to move graphics power where it was most needed and it has worked well in most respects. The only problem we’ve seen is that grasshopper preview graphics (prebaked geometry only) shows wavy edges as in the screenshot below. But baked geometry, and Rhino geometry generally appears normal. Anyone have any idea as to why this would be happening and how it might be fixed? I would love to deploy this hardware solution firmwide (for among other reasons, we think it will encourage users to learn more grasshopper if they aren’t chained to their desktops in the office) but I want to understand this problem before we move ahead so I know what we can and cannot expect when we get into large complex models and definitions.


(Nathan 'jesterKing' Letwory) #2

Are you creating geometry far away from origin? Or extremely large?


#3

Exactly the problem! Good call. Thank you.

Otherwise the external GPU has been an excellent solution. If we run into other problems, I’ll post about them here.


#4

Just curious, how far is very far? Not that I use it to that size.


(Nathan 'jesterKing' Letwory) #5

Hundreds of thousands I think, haven’t really tried to find out.

In many cases it is enough to pick the model unit such that largest coordinates run in the thousands, maybe tens of thousands. At least when it comes to drawing. For instance drawing something that is 100m x 100m it doesn’t make much sense to use mm as unit setting, since on that scale sub-mm detail wouldn’t be visible.

Using large coordinates eats precision after the decimal separator. Especially drawing suffers from that, since most data is used in float format. Double format would obviously be better, but also require double the memory.


#6

Thanks @nathanletwory, definitely won’t use that far.
I’ve seen couple of threads before also so was just curious.


#7

Wouldn’t this be an issue no matter where the GPU is? Also why just grasshopper preview graphics? Andrew made it sound like it was unique to his external GPU setup. @Andrew_Cocke: Didn’t this show up on desktops, notebooks or workstations with built-in GPU’s?