Grasshopper Extruding Issue (3D Print)

I have narrowed down to my issue to where once I extrude the geometry and export it into a slicer (Prusaslicer/Simplify3d), my geometry gets deformed. Within Rhino viewport and vray render, they look perfectly fine.

Lacking your GH file to check out my guess is you have stumbled onto the Rhino issue of inability to deal with fillets correctly. If this is indeed what’s going on you can fix it by invoking the following Rhino command after you have baked your geometry:

_DivideAlongCreases _SplitAtTangents=_Yes

To make it easy to invoke this command from GH I put this command into a toolbar button macro and stuck it on one of Rhino’s toolbars.


Looks like you probably need more polygons when you export your extrusion from rhino to another.(Especially for the narrow curvy portions)
You can find the control options when export.


Thank you! this solved my issue!

Hi Eddy -
Since this issue is with the Extrude component not having a kink-splitter input, you can easily work around this by extruding individual curves - as opposed to polycurves.
Something like this should work:


1 Like

This also solved my issue too!