Baked Grasshopper breps not meshing properly in Rhino

i ran into an issue trying to mesh polysurfaces in Rhino that i had baked in GH.
if i extrude the original curve in Rhino and mesh that polysurface it meshes fine.
if i extrude the curve in GH. bake it. and mesh it in Rhino with the same settings it looks like the following.
(settings: simple, default)

btw, by now i found some kind of solution:
if i mesh the GH-extrusion inside GH the mesh looks fine again.

but i’m still wondering what the issue is.

GH-meshing-issue.gh (3.7 KB)
GH-meshing-issue.3dm (4.0 MB)

i’m on

macOS 12.2.1 (21D62)
Rhino for Mac Version 7 (7.19.22180.09002, 2022-06-29)

Hi @Felix_Groll ,

This appears to be due to GH’s Extrude component not splitting the surface at the input crvs knots while directly extruding in Rhino does. You could work around it this way too… Explode the crv > reference the pieces > GH Extrude > GH Join. The issue is that if that side wall is one single surface the simple render mesh settings won’t be enough to capture the fillets.

Now is this a bug or something to change in GH?.. I’m unsure. I can see the benefit of the single side wall srf there.

I believe you have stumbled on a Rhino quirk I discovered a few years ago. The problem has to do with the filleted corners in your geometry. When you create them in GH they look fine, but when baked into Rhino something bad happens and the fillets may or may not get whacked off and turned into chamfers. Needless to say I have no idea why this happens.

The fix I came up with is to bake the geometry and then, even if it looks OK, select it in Rhino and run this command in the Rhino command window:

_DivideAlongCreases _SplitAtTangents=_Yes

I actually ended up making a special macro button that I put on my Rhino toolbar for this function. It looks like this:

I do this before exporting the baked geometry as an STL file I use for 3D printing. But you should do it before you convert the baked geometry to a mesh, and then do what you want with the mesh.