Grasshopper doesn't show geometry with any drawing mode except drawing for selected objects


(4boldyreva) #1

Hello! I will be incredibly happy if somebody knows how to fix the problem that I just got.

I can see geometry only if I press “draw only selected”. It’s happening only with the current file. If i create a new one, I can see geometry. In previous version of the algorythm (that doesnt have too many changes comparing with the whole code that is quiet big) everything is ok as well.

Previous time I worked on the algorythm I saw everything, I saved it, today I opened it and got the problem. I already tried to copy paste all code to a new file. It didn’t bring any result.

Anybody got this? Is there any solutiuon?

Thanx a lot!


(David Rutten) #2

It is likely then that one of the objects which is drawn as part of the regular preview is causing an error, and this short-circuits the entire preview. To narrow it down you can select all your objects and disable their previews via the MiddleMouseButton or SpaceBar menu. Then select the left half of your file and enable the preview, does it work? If yes, then the error is happening in the right half, if no, then disable the preview again and only select the leftmost quarter. This way you should be able to find the offending object soonish.

ps. if you have the Selected Only = Yes option on, and you select everything, does the preview work?

pps. are there any error messages printed to the Rhino command line that might hint at where the problem lies?

ppps. what version of Rhino/GH are you using?


(4boldyreva) #3

David, thanx a lot for your answer! It helped!
I didn’t find the exact component that crushed? but anyway everything works.
I selected all algorythm, disabled preview, after I tried to find a part that didn’t work, fount it, disabled preview and everything started to work. After I opened the part that didn’t work again, but it worked anyway.
Thanx again!!