Grasshopper crashed while I tried to open a file from Win10 on Mac (M1)


I tried to open a grasshopper file that was created on different OS (windows 10) and then the software is crashing.

If anyone can help I will appreciate that.

I also tried to create a new grasshopper file and copy the components to the new file but I still got the same results.

The headers of the traceback is attached (the full traceback is 44 pages):

Process: Rhinoceros [881]
Path: /Applications/Rhino
Identifier: com.mcneel.rhinoceros.7
Version: 7.14 (7.14.22010.17002)
Code Type: X86-64 (Translated)
Parent Process: ??? [1]
Responsible: Rhinoceros [881]
User ID: 501

Date/Time: 2022-02-09 00:24:38.978 +0200
OS Version: macOS 11.6.2 (20G314)
Report Version: 12
Anonymous UUID: 4E8F742A-3B97-F255-852A-3EA8BEB6488E

Time Awake Since Boot: 170 seconds

System Integrity Protection: enabled

Crashed Thread: 2 SGen worker

Exception Type: EXC_CRASH (SIGSEGV)
Exception Codes: 0x0000000000000000, 0x0000000000000000

Termination Signal: Segmentation fault: 11
Termination Reason: Namespace SIGNAL, Code 0xb
Terminating Process: Rhinoceros [881]

Application Specific Information:
Performing @selector(__monomac_internal_ActionDispatcher_activated:) from sender NSMenuItem 0x600000ccde30

Thread 0:: tid_103 Dispatch queue:
0 runtime 0x00007ffdffc2f5ac 0x7ffdffc18000 + 95660
1 runtime 0x00007ffdffc2fab8 0x7ffdffc18000 + 96952
2 runtime 0x00007ffdffc2aaa4 0x7ffdffc18000 + 76452
3 runtime 0x00007ffdffc2db18 0x7ffdffc18000 + 88856
4 ??? 0x00007ffe94756b00 ???
5 libsystem_kernel.dylib 0x00007fff2031ddf2 __sigreturn + 10

Thread 1::
0 runtime 0x00007ffdffc1ca28 0x7ffdffc18000 + 18984
1 runtime 0x00007ffdffc21eec 0x7ffdffc18000 + 40684
2 runtime 0x00007ffdffc232c0 0x7ffdffc18000 + 45760

Thread 2 Crashed:: SGen worker
0 ??? 0x00007ffe947568f4 ???
1 libsystem_kernel.dylib 0x00007fff20317cde __psynch_cvwait + 10
2 libmonosgen-2.0.1.dylib 0x000000015b8caca3 thread_func + 227
3 libsystem_pthread.dylib 0x00007fff2034a8fc _pthread_start + 224
4 libsystem_pthread.dylib 0x00007fff20346443 thread_start + 15


Hi Yitzchak -

Can you post that Grasshopper file?

I’m not sure what that means…

Please run the Rhino SystemInfo command and copy-paste the result here.

Hi wim,

Thanks for your reply.

Unfortunately, I can’t post the Grasshopper file now but I hope I still can get some help.

I thought maybe the grasshopper file itself is broken or defective in some way so I have tried to create a new file on my Win10 and then copy the grasshopper’s components from the old file to the new one and when I tried to open the new file on the Mac (M1) I got the same crash.

The SystemInfo:

Rhino 7 SR14 2022-1-10 (Rhino 7, 7.14.22010.17002, Git hash:master @ d8a2d020be8cb487bfc091316ef32170cfc7eddb)
License type: Evaluation, build 2022-01-10
License details: Stand-Alone
Expires on: 2022-05-02

Apple macOS Version 11.6.2 (Build 20G314) (Physical RAM: 16Gb)
Rhino is running in Rosetta2 on Apple Silicon
Mac Model Identifier: MacBookAir10,1
Language: he-IL (MacOS default)

Apple M1 (OpenGL ver:4.1 Metal - 71.7.1)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: Apple
Render version: 4.1
Shading Language: 4.10
Maximum Texture size: 16384 x 16384
Z-Buffer depth: n/a
Maximum Viewport size: 16384 x 16384
Total Video Memory: 10922 MB
Graphics: Apple M1
Displays: Unknown (255dpi 2x)

Graphics processors
Apple M1
Color LCD (1440 x 900 @ 60.00Hz)

USB devices

Bluetooth devices

Third party kernel extensions

Third party plugins

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
/Applications/Rhino “PanelingTools” 7.14.22010.1002
/Applications/Rhino “Displacement” 7.14.22010.1002
/Applications/Rhino “Renderer Development Kit” 7.14.22010.1002
/Applications/Rhino “Snapshots” 7.14.22010.1002
/Applications/Rhino “Legacy Rhino Render” 7.14.22010.1002
/Applications/Rhino “Commands” 7.14.22010.17002
/Applications/Rhino “Import_OBJ” 7.14.22010.17002
/Applications/Rhino “export_xaml” 7.14.22010.17002
/Applications/Rhino “QuadRemesh” 7.14.22010.17002
/Applications/Rhino “export_OBJ” 7.14.22010.17002
/Applications/Rhino “RDK_EtoUI” 7.14.22010.17002
/Applications/Rhino “Export SVG” 7.14.22010.17002
/Applications/Rhino “MeshCommands” 7.14.22010.17002
/Applications/Rhino “Export_DAE” 7.14.22010.17002
/Applications/Rhino “PDF Export” 7.14.22010.17002
/Applications/Rhino “IGES Export Plug-in” 7.14.22010.17002
/Applications/Rhino “Import_SVG” 7.14.22010.17002
/Applications/Rhino “BlockEdit” 7.14.22010.17002
/Applications/Rhino “Export_AMF” 7.14.22010.17002
/Applications/Rhino “Rhino Render” 7.14.22010.17002
/Applications/Rhino “Import_DST” 7.14.22010.17002
/Applications/Rhino “PLY - Polygon File Format Export” 7.14.22010.17002
/Applications/Rhino “Import_AMF” 7.14.22010.17002
/Applications/Rhino “RhinoCycles” 7.14.22010.17002
/Applications/Rhino “IronPython” 7.14.22010.17002
/Applications/Rhino “Grasshopper” 7.14.22010.17002


Hi Yitzchak -

Perhaps you can upload it to tech support so that it’s not posted publicly? Make sure to copy the URL to this thread in the comments field if you do.

So that means that the Grasshopper file still opens fine on Windows?
Can you “divide and conquer” by copying parts of the definition (internalizing geometry or other data where necessary) into a new one and test that on your Mac? That might reveal a single component that is failing.

I’ve quickly checked other system info reports from people on M1 hardware - they are all running macOS Monterey. Have you tried / considered updating your OS?

Hello Wim,

My OS is updated right now and the problem remains the same.

I heard your advice to take the approach of “Divide and Conquer” and I found the problematic component, a GHPython component with the following lines:

import rhinoscriptsyntax as rs
import Rhino as rh
from System.Collections.Generic import *
from System import *

if x:
    ghdoc = ghenv.Component.Attributes.Owner.OnPingDocument()
    rhdoc = rh.RhinoDoc.ActiveDoc
    componentsToBake = [obj for obj in ghdoc.ActiveObjects() if obj.NickName == "Final Preview"]
    for component in componentsToBake:
        ids = List[Guid]()

This is a short script for baking a geometries using a one click button.

Do you have any idea why it’s causing a problem?
Alternatively, do you have any idea how can I bake a geometry using a python script that supported by Mac?

Thank you,
– Y

Hi Yitzchak -

I can confirm that this crashes on 7.14 on Mac but was fixed at some point and doesn’t crash on last week’s 7.16 Service Release Candidate. I didn’t dig deeper to find the exact version that fixed this but I’d at least try the final 7.15 release and, if that doesn’t do it, change the update setting in the Rhino Preferences.

Hello there,

The final 7.15 release didn’t solved the problem but updating 7.16 Service Release Candidate was the solution.

Thank you very much for your help, I appreciate that.


1 Like