Grasshopper cannot join curves, is there a tolerance option?

I cannot join some curves, is there a tolerance option to join the non-joining curves?

problem join curves (643.0 KB)

Where’s the problem? Your curves are a mess. You have a lot of overlapping curves. It join’s as much as possible on my computer. (54) and you get that much intersection points at the marked area because there are 3 overlapping curves.

Join combines lines if both lines share the same start/end point (as i know) and is not cleaning duplicated/overlaying ones.

Sorry, for my many replies. I tried to solve my problem.
I found overlapping curves, but I was not able to delete them.

What I am trying to do is to connect the curves as one continues curve. I also tried another setting, but it seemed to fail (I did not ad that to this file).

problem join curves (644.9 KB)

How did you get ‘when same end points, join?’

Simply like that:
problem join curves (647.2 KB)

If you still don’t like the intersection points, it’s because of “bad” curves. Sometimes to stresslines are near to each other, intersecting, but aren’t duplicated ones. For example:

1 Like