Grashopper Python TCP Socket Communication Freezing/Not Responding / Delayed (1023 Bytes) (2.7 KB)

Hi all,

This is a small trouble I am having when I am trying to communicate with a python script and a GHPython script using TCP Socket communication. the respose gets freezed, delayed or not responsive after 2-3 iterations.(attached screenshot) Somehow the server won’t send the data back and the client wont finish communication with the server. But when I run the same script through 2 terminal windows they communicate perfecty.
But when i try the same with UDP it works perfectly. Previously we have used TCP Socket communication to read data from a UR10 and it worked perfectly. I have attached the files here.

Can anyone tell me what could be the issue here?

P.S. I have also found a paper where it suggests that GH does not support socket programming over TCP protocol.
Link to the paper.

Thank you

Perhaps it’s an IronPython issue (i.e. the .NET flavour of Python that Rhino/Grasshopper uses).

I looked for similar problems faced by others but there are no instances of this one yet.