Glass Rendering Properties

Hey guys,

I have a probably very simple question about the behavior of glass in V-Ray:

In the image you can see a very simple model of an exploded box, where two sides are glass (Glass_Window_Neutral) and the other concrete. However, the thing is, that the glass is behaving as if it was a solid, however I did not change any of the settings and the IOR should be fine…

Basically, I just want it to look like a thin sheet of glass. Are there some settings that I missed?

Greetings, Rudi (927.8 KB)

A single face has no thickness so a renderer treats it as a solid until it (the ray) hits another material. Therefore most advanced renderers has a “thin material” setting of some sort. But you can work around this by either giving it a thickness (as it would have in real life, alas model the thickness) or add the “thick” feature to it in Rhino IF your renderer handles those features from the Rhino RDK. You find Thickness together with Edge Softening:


Hi Rudi,

The easiest thing to do is to set the Refraction IOR value to 1.0.
Then make sure that the Reflection IOR is enabled and set to a value you like.


1 Like

yes, but then you won’t get a visible edge indicating the glass extent.

Sure Holo,

Your suggestion is the correct approach.
The object and material will certainly appear more natural with physical thickness.

On the other hand, sometimes modifying the geometry is not an option.
That’s why I suggested the workflow.


1 Like

Of course you’re right, and that’s why I said ‘yes…’ and not ‘no…’ :wink:

1 Like

Thank you a lot!!!

hey again!

there is another issue:

when rendering the glass, looking through it, the background hdri is not being rendered/turns black - whereas the other Elements appear perfectly…

Would be cool if you could help me here.

Greetings from Stuttgart,

Rudi (31.4 KB)

…interestingly this only happens in V-Ray for Grasshopper…

Now this is a thing I’m also interested in. Keyshot users can also see the HDRI image distorted behind the glass, but V-Ray won’t do that as far as I know.

In your case you might try to boost the HDRI multiplier to 10 or so and see what happens. :-S


It’s no problem for V-Ray, maybe something is wrong at the GH way.

That’s a nice one! Do you use HDRI background via Environment slot? Hmmm maybe my problem was missing distortion with a standard photo used in “Screen” mode.

I tested it now and you are right, in this case it doesn’t work. In this case only it helps to use the old Rhino screen mapping tool which apply a screen mapping to a mesh object in the background. Here a test. The black glass areas are the area from outside my background plane. (A pano with an equal landscape in the refraction slot at the environment options would help here.)

Wow, thank you, I will try to make it work too.

That glass cube looks super-real.


One nice feature I ignored in the past is the dispersion. I enabled it here. I’m very happy that expensive effects like dispersion or high reflections depths are rendered so fast. Maybe it’s the GPU mode and the two 2080ti.

I can confirm this. Dispersion on, with a shitty CPU and progressive + nvidia denoiser. I even believe nvidia denoiser is also improved in 4.1.

Hi guys,

The Dome Rig in Grasshopper works in a slightly different way compared to just a simple dome added to the scene.
We have the HDR connected to both the Dome texture and the V-Ray Background in order to expose two separate intensity values.

There might be something wrong in this underlying setup.
I’ll check and let you know.


Confirmed - there is an issue with the underlying setup.
We’ll have a fix for it in the next version - V-Ray Next for Rhino, update 1, hotfix 1

Thanks for reporting this Rudi,

1 Like

Sure thing - thanks a lot!