Ghpython remote cannot locate %PATH%

Hello all,
to summarize:

  • conda environment
  • created virtual environment ghenv and installed python 2.7.17
  • installed ghpython through pip following instructions
  • opened examples
  • get this error message
  • any suggestions?

Goal here is to utilize as many python libraries as possible, and even develope directly in spyder and import code over. Short of learning C# this seems the best way to develope apps, no?

bump! Really need to figure this one out stat,
apperciate it!

I remember facing similar problem before, what is the locatiom you input ? and also i think you need to make sure that this version of python is installed in your path in the control panel, also anaconda

FIXED: Inside the example Ghpython-Remote script there is a panel “location.” I added the location to my conda remote instance with python 2.7.17 and it worked fine.


  • Under the modules panel, stock they have: numpy, scipy, numpy.linalg.
  • these all work great. Problem is when I try to add one such as matplotlib, does not work…
  • tried with a few packages. ideas?


Are you sure that you have already downloaded mathplotlip in your conda environment first?

hold on, so If I install a remote instance of conda, then I have to install all the required libraries I need? I c, I c.

You should have the libraries you need already installed in the virtual environment, otherwise pythonremote will not be able to find them

okay with python 2.7.17 installed I pipped: matplotlib

  • works in GH
  • cannot access matplotlib.pyplot (not to mention other matplotlibs…
  • whats the deal?


Alternative question: If I script in c#, can I skip all this bs? Can I access all available c# libraries immediately?


Do you import the library using this method ?

yes. With Python 2.7.17 Matplotlib does not have .pyplot.

umm I dont know why but let me try and will back to you if i managed to import it


You give it a try? Real question actually: I use anaconda/spyder, can I remote visualize 3d geometry with that? Anyway to ‘compete’ with a CAD platform like Rhino? I want to do all sorts of surface manipulations and such.

sorry for the late reply
I tried it but had the same issue
I think it is a common problem, maybe you find this thread useful

Yea honestly at this point may be worth just switching over to c# and vscode

1 Like