Ghcomp.evaluatecurve problem

Hi everyone

I have a strange problem trying to use a ghcomp. to evaluate a curve at parameter 0.

I have just finished a script where I’m using the same ghcomponent code evaluating at the start of a curve, and it works fine there, with the same sort of input, curve and 0 parameter.

Then I tried to do it in Grasshopper just with actual gh components, and that works.

I also tried with rhinoscriptsyntax and that works too.

I know, I should be using rs but Im much more in my comfortzone using gh components, since I know the in and outputs from actual GH use and I can also recreate some of scripts on the side on the canvas.

I have no idea why its not working now

Thanks, Rasmus

Evaluate curve - GH (13.4 KB)

It seems to be fine in Rhino 6.

Rhino version 6 SR19, 6.19.19255.23431.



Giulio Piacentino
for Robert McNeel & Associates

Thanks Giulio, and thanks for the swift reply

I am on Version 6 SR8
(6.8.18240.20051, 08/28/2018)

company pc, so not sure I can update.

however its strange since I used the exact same code in another script earlier, evaluating at the same parameter, 0, and that works fine. Now I just get Null values.

Unless you can update, there is not much I can do. A fix would come in an update anyways.
Also, it’s likely this got fixed in a SR. We published a couple of important upgrades for this library since SR0, and this might have been part of the fix.

Thanks again.

I did the old faithfull IT solution - shut everything down and restart, that worked… :upside_down_face:

Going to try and see if I can update Rhino too.


It would be great. If you manage to update, please let me know if this fixed the problem for good.