Galapagos - Buggy when running Evolutionary Solver


I’m running an optimisation with Galapagos which is relatively data intensive and I’m seeing some strange behaviour of the solver. It seems hang during solving and the epoch window displays as shown below. If I leave it on the solver tab galapagos seems to stop entirely; if I click on to the options or record tab, it continues solving for further iterations, but the solver tab remains effectively frozen.

This also seems to stop the runtime rules from working so I have to manually stop the solver. When I stop the solver, the graph remains solid yellow but I’m able to select solution. Reinstating solutions causes Rhino and GH to freeze for around 30 seconds.

I suspected this was because my computer was underpowered, but I’ve tested on a high performance desktop and the behaviour is the same.

Hi Andrew -

Could you provide an sample gh file that shows this behavior?

Hi Wim,

Unfortunately I’m not at liberty to share the script, and it pulls data from an external database; however I can provide a description of the basic function:

  • Geometry parameters read from XML file with Python nodes
  • Geometry assembled in GH, then a structural model is assembled in Karamba.
  • Karamba results used to make structural checks within Python nodes - outputs an element %age utilisation.
  • Use pick/choose node to generate fitness value - optimise against total element mass; but if any element utilisation >100% pass null value (generated from DIV/0)
  • Genome connects to multiple sliders which define the likes of support locations, elements properties etc.

The problem will inherently generate a lot of invalid (null value passed to fitness) results. Do I need to adjust my solver options to accommodate this? Is the issue that there are a lack of value solutions to carry over between epochs?


To add to this, Simulated Annealing appears to behave normally (however, I am less familiar with this solver and I’m not sure how well suited it is to my application)

Hi Andrew -

Testing that hypothesis, I was able to reproduce that issue here and put it on the list.
RH-72816 Grasshopper: Galapagos goes yellow

That’s Wim - I’ve dropped you a direct message. It may be that the sample problem I’ve set up is overconstrained. Would adjusting the solver settings assist in any way?

Hi Andrew -

I’m afraid I’ve no idea. The issue is on the list of the developer to take a look but I don’t know when that will happen. Your best bet at this point is to look for an alternative, either the simulated annealing solver or one of the other evolutionary solvers that are available for Grasshopper, such as Wallacei…