From Stereo to Mono?

unhandled

#1

V5 has this:
image

Is it no more available in V6?
This stereo view is needed.


Stereo viewport mode in Rhino 6
#3

@Pascal

I couldn’t find a comment or something on this on YouTrack.

Do you know more?


(Jeff Lasor) #4

Stereo modes were pulled out of 6.0 until we have time to figure out a better implementation and integration into the product. Hardware stereo modes have always been a thorn in Rhino’s side due to all of the different types of configurations that can exist, and all of the different user expectations that went along with them. It was decided that since we were pulling hardware stereo mode support, that we should also just pull all 3D Stereo support for the time being until we can address all issues on the matter.

It may be possible for me to put together a simple plugin that just gives you an Anaglyph Stereo mode if this is something you really feel you’re going to miss. As far as we can tell, not very many users use this feature, much less even know it exists/existed.

Thanks,
-Jeff


#5

Hi Jeff

While I’m willing to understand the technical aspects, I can’t understand how this feature could be stripped off without any notice.

It is said that V6 has improved display (yes, it is a lot improved, no question).
It is not said that the stereo feature is gone for now.
That is a step backwards from V5.

Understood and agree.
Then remove the hardware support until a common VR interface is established.
I can’t imagine that you will be bored someday and then work on the hardware mode.

I don’t understand.
Were there any issues regarding the anaglyph mode?
In YouTrack I couldn’t find issues…

Why remove a good working feature?
Why not only remove the hardware mode?

Yes, I do miss it.
A plugin would be nice.
At best included and activated in the standard installation.

With this argument you could easily drop many many good features.
I hope you don’t.

Charles


(Jeff Lasor) #6

Hi Charles, I wasn’t saying that as a reason or an excuse… more just an observation on my part. I’ll see what I can do to resolve this for you… It turns out that a lot of this has to do with the improved display and its features…the stereo mode feature was just not cooperating well with the new design, which is why we made the decision to pull it (temporarily)… And the issues aren’t just hardware related, it’s the entire “stereo” mechanism in general… In order to get any kind of stereo effect, Rhino needs to render two frames, each from a different camera perspective, and then those results are merged into a single image (either by hardware or by software (i.e. anaglyph)… It’s the process of re-drawing the entire scene twice that needs to be looked at and reworked so that things work better in the new architecture. So we didn’t remove something that was working…quite the opposite…we removed it because it was not working and it was deemed that in order to get things working would have pushed schedules back further than we wanted. Sorry if I didn’t make that clear before.

We will get something working in 6.x in terms of stereo support, I just can’t tell you with any certainty when that will be.

Thanks,
-Jeff


#7

Thank you Jeff for the explanation.

You say the anaglyph will come back.
I hope it won’t be a long wait…

In the meantime, a plugin will help.
It must not be super-fast, it is very clear that the rendering will take at least the double time.


(Jeff Lasor) #8

@Charles Please find attached a rough draft of an Anaglyph Stereo view plugin…

Download and save the plugin somewhere appropriate on your hard driver, and install the plugin using the plugin manager…or whatever way you’re comfortable with.

Once installed, you will have a new Panel Tab choice of “Stereo View”…

Showing the “Stereo View” tab will reveal all of the anaglyph settings along with a list of views within your current layout… Simply CHECKing and UNCHECKing a specific view will enable and/or disable stereo mode for that respective view.

Settings are remembered across Rhino Sessions, and not saved per file.

Let me know if you have any questions, and of course what you don’t like (or like :slight_smile: ).

Thanks,
-Jeff

See post further down for latest version of the plugin


#9

Hi @jeff,

thank you, I like it.

Michael
www.flexiCAD.com


(Jeff Lasor) #10

Thanks @Michael_Meyer,

Let me know if you run into any issues… Wouldn’t you know it, two minutes after I posted it, with tons of testing ahead of time, I found a bug…

I’ll wait to compile a list of bugs from you guys before pushing out another version…

Thanks again for feedback and testing.
-Jeff


(Jeff Lasor) #11

@Michael_Meyer @Charles …

Update… (sorry couldn’t wait)…

Please use this latest version (1.0.1) … Just save it over the top of the existing one if you’ve already installed it.

Note: Make sure Rhino is NOT running when you do this.

Thanks,
-Jeff

StereoView.rhp (300.5 KB)


#12

Hi Jeff

Good news, great Monday morning…!

But not completely:
The Parallax slider doesn’t do anything in here.
The initial setting was 3.3 (if my memory is correct).
The slider only changes the numbers, not the view.
So I don’t get a good image.

Hmm, now it works as expected.
Don’t know why… no problem.

I like the panel approach.
Far more comfy than set up in a display mode.


#13

just out of curiosity, do you actually model in this mode or why do you need it? i painted myself 2 foils and tried it, it was of course not very satisfactory but it worked.


#14

No, modelling is not possible in stereo.
First some feedback elements are still mono. Second you will get some headache.

Stereo is quite useful to judge over designs.
Especially for folks that are not so very used to 3D CAD.


(Jeff Lasor) #15

I certainly can attest to that! :slight_smile:
-J


#16

Thanks for the plugin. I also find it a quite handy feature from time to time to check the 3d form of a design in more detail prior to 3d printing it.

Question, is it possible to get the plugin working also with the preview mode of Grasshopper somehow? When I tick the viewport in the plugin all Grasshopper elements disappear unfortunately.


(Jeff Lasor) #17

Thanks @DM9,

I was unaware of the Grasshopper issue… I’ll take a look at it and post a new version if/when it’s fixed.

Thanks again,
-Jeff