Filleting Nightmare and Ongoing V6 Weirdness


V6 Issue. If I try to make any fillets (fillet edge) to the red object, there is no problem. However, when any one of the three surfaces from the F’d layer are joined to the red object, then I can’t even select an edge when trying to create a fillet. Pick and edge, any edge!

If I export the poly-surface fully joined to the surfaces in the F’d layer as a V5 file and then work in V5, there are no issues and I can actually get my work done.

The questionable surfaces all check out as valid. They were made by Fillet Edge. Am I doing something fundamentally wrong? (Before anyone pipes up with the benefits of using Fillet Surface and doing things manually, I’m aware but just need to get work done rapidly for experimental prototyping.) Is there a better way to make surfaces with a draft angle than using Extrude Curve Tapered so that I don’t have these problems when I go to make fillets? And is there an easier way to find these problem causing rogue surfaces without a tedious and time-consuming process of elimination? This process seems so preposterous in the era of mature CAD software.

I’ve been having way more confusion/problems/despair and just general slow performance with V6 than I’ve ever had in V5. (SystemInfo file attached.) Has something fundamentally changed in V6 to be causing me difficulties I wasn’t having in V5? For the record, I’ve had a paid license since midway through V3, so at least a decade of using Rhino at least 4 days a week for at least 4 hours a day. While I’m not a leading expert, I’m not a beginner.

If this post is in anyway obnoxious or incoherent, I apologize. I’m up against yet another deadline. It feels like I’ve been fighting with V6 for several months and right now I’m enjoying perhaps a bit too much 120 proof bourbon and trying to garner the courage to pull an all-nigher. Feel free to delete the post if you deem it offensive. I’d still appreciate a private email response.

SystemInfo.txt (2.0 KB)


The FilletEdge prompt says it fails because there’s a “creased surface” in the polysurface. “Ignored 1 edge in object with a creased surface. Use DivideAlongCreases to fix the object.” It’s one of the fillet surfaces that gets broken up. A creased surface isn’t automatically ‘bad’ so SelBadObjects doesn’t pick them out but I guess V6’s filleter doesn’t like them.

I generally find V6 exponentially faster myself. Maybe a few cases of filleting like this where V5 can get something out with less hassle? Of course if you find those you should submit them. I’m sure rewriting stuff to support editing after the fact changed a lot.

Taking a look for a problem area that … one I see is where the large lower face on the …back side? meets the upper faces with a sharp crease at a very slight angle(like close to your tolerance,) it would be cleaner if that had a fillet across it…the way I’d fix this is to just take what FilletEdge gives me then fix it up with surface techniques, that can be much faster than trying to track down every issue that’s screwing up FilletEdge.

Thanks for the reply, Jim. Where do you get the FilletEdge prompt warning about the creased surface? I don’t get anything. I can’t even select an edge to get a failure or prompt. And more to the point, how do I go about not creating those creased surfaces in the first place? Finally, either one of the 2 surfaces on the F’d layer caused the problem. How does one crease somewhere cause 2 separate and not in anyway connected surfaces to cause the problem?



in my oppinion filleting is the most difficult thing you can do in surface modelling, especially corner blends with more then 3 edges.
This means algorithm doing this fully automatic, are one of the most difficult and advanced commands in any CAD program. Its not trivial, even in 2018.
Now there are many cad platforms out there which perform better here, but they a. don‘t provide such a rich toolset as Rhino or b.if so, they are much more expensive.

Furthermore if you want to automate this you almost always pay the tradeoff in quality and controllability. In your case I can only encourage you buying a second CAD platform, because if you put a pricetag on your time spend filleting something and compare that to more expensive software, you immediately should see the benefit of buying a second platform. Many users here quote Solidworks as perfect tool in an acceptable financial frame. For quick filleting I personally prefer Catia, because its auto filleting is extremly reliable, even on very difficult situations.
But even regarding manual filleting, Rhino isn‘t simply the best tool for. My advice: Always value the combination of 2 or more CAD applications! Not a or b. And stop being picky because of the price. Its roi is pretty high.

I’m quite aware of the filleting limitations in Rhino and other surface modelers. I understand how to manually make more complex fillets. But when I can’t make a simple single edge fillet in V6 (or in this case can’t even select an edge to make them) when they work just fine in V5, and V5 doesn’t seem to make as many problematic surfaces, it’s not a step forward. It’s a potential bug or I need to learn what I did wrong. And, in my experience, V6 is making so many more problematic surfaces/polysurfaces, which is why I asked if I was doing something fundamentally wrong with the latest version. Right now, I’m having to work with Rhino as if it were two CAD packages by switching between V5 and 6 constantly. But truth be told, I’m getting more done in V5 so I’ll keep using that.

Finally, where did I mention being picky about the price of anything? Pointless and condescending replies stating that you should spend more money on other software isn’t answering the question(s) or taking into account that others may not have that option. For the record, I have access to SW and Fusion, just not at the location i’ll be stuck at for the next few days.

Don’t be so rude man. I don’t think my answer is pointless at all. Might have chosen the wrong words though. Sorry for that. But what kind of answer do you expect? Its a fact that Rhino’s filletedge is by far not the best algorithm out there, and the only helpful answer here is saying, then use another software for that. V5 didn’t do a better job and McNeel is working on it, but obviously you cannot solve the problem in 2 days. Or you build it completely manually. But then _FilletSrf is the right command.

I think that you’re misunderstanding the issue. With the file I attached, I can’t even make a very simple, single edge fillet. I can’t even click on the edge after I start the FilletEdge command. So, from my point of view, your reply didn’t even notice my question. My apologies for unintended rudeness. It’s late here and I’m tired. And I still don’t have an answer.

1 Like

You are right, haven’t seen the model when replying first. sorry for this. :slight_smile: I don’t know an concrete answer to why its failing there. I for myself only use fillet edge on simpler cases. When its getting more complicated, I switch to Catia for quick filleting and Icem Surf for high end fillets. I encountered too many failures, even on simple and clean geometry with _filletEdge. So basically I ignore that as often as possible. My mindset regarding this command is: Have a try but don’t rely :smile:

I agree that this is a strange case, I haven’t encountered this particular fillet error before (maybe I’ve been lucky). Zooming in close, I notice some misalignment on the edges of the smaller fillet surface (black), and you’re left with the tiny naked edges when you join it. This usually means trouble in my experience.

I do a lot of modelling moulded components in a similar vein, and I find the best approach is to be very diligent in keeping things clean. I would make sure non-freeform surfaces are split at tangents for example, all coplanar surfaces are merged etc. Anything to keep the surfaces as clean and simple as possible. In my experience this helps with filleting but is by no means a guarantee it will work.

Unfortunately, Rhino isn’t the most forgiving modeller. Even if you take your time, work diligently it can still catch you out. When that happens, finding the issue manually is usually the only way.

I dunno, it just appears on the command line on my V6. The ‘bad’ surface was created by FilletEdge itself, and I’m not real sure why, that’s not something it should do. It throws the warning even though the fillets don’t touch the creased surface because it doesn’t care about that, it just notices it and says hey hey no. It’s frankly not an exact issue I’ve ever run into before.

Hi Bjorf - if you run DivideAlongCreases > SplitAtTangents = Yes, those f’ed surfaces will be broken up at their tangents and FilletEdge should do its thing OK. V5 likes it better if the whole part split up at tangents as well.

I’ll poke at this some more.

The tolerance in the file is .012 - that is maybe a little fat - I’d think it should work OK, but still I’d be inclined to model at .001 for objects of this scale.


Not sure if this is useful, because it’s a 2 years old thread but while I was modelling a quite challenging part I find myself at the exact same situation.

I tired the divide along creases command and it just make things worse, funny thing is that yesterday the fillet edge was working ok.
Tried to restart rhino, restart pc nothing worked.

The solution at least in my case was to export the geometry I needed to work with to STEP, then delete it from the rhino file, then import STEP file. Things are working correctly again.

Maybe the surface rebuilding done at the import phase is the trick.

Hello - no way to help or comment without the file…