.fbx edge creases not importing correctly

If i import a mesh from 3ds Max and select “import mesh as subD surface” the edge creases are in the wrong place
If i import a mesh from Maya and select “import mesh as subD surface” the edge creases are completely missing

But if i import a mesh from 3DS Max to Maya the creases are correct

Is this just a bug with Rhino?

I believe this has to do with how a weighted crease is defined in the mesh modeler used to create it. Rhino SubDs weren’t introduced with the ability to make variable sharp creases due to the requirement of making NURBS polysurfaces from them and this taking precedence over interoperability with mesh modelers that support weighted creases for their SubD meshes. We are working on weighted creases for SubDs in the v8 WIP though via the new Sharp command. I am not sure how the math making this possible on Rhino SubD surfaces will translate or if it even can with poly modelers like 3DS and Maya. I believe those two apps may know about how the weighted creases are defined and do some sort of translation to support them. If you can post an obj or fbx and a screenshot of what it should look like once imported and SubD’d in Rhino, I’ll make sure it gets in front of the devs to see if we can keep the weights or not.

1 Like

Dale Lear talks about it here

I believe this problem is caused by a bug in the current FBX toolkit that Rhino must use to read FBX files. This used to work when we were able to use an older FBX toolkit.

Please see these two links.



1 Like

When using a model taken from 3ds max rhino puts the creases on the wrong edges, so i dont think its just a weight issue

Would using an older version of rhino fix the issue?
Where can i download older versions?

Hi, Thomas,

I don’t know the answer to you question. I’ve asked for help from @tim who knows the most about Rhino’s file IO support.

Hi Thomas,

Yes, using an older version would work around the problem. Looks like the SDK was updated for 7.25.xxx so you’d need the last version published of 7.24. If you have it then you could use that. If you don’t, let us know and I’ll see if anyone here has objections to making it available to you. Nevermind, I see you asked above where you can get it. I’ll ask.

Incidentally, I did ask AutoDesk about the problem (Dale posted the link above) when we realized it was the SDK update that broke it but I didn’t get a single response so I guess they have no interest in fixing it. We were forced to update the SDK because of security vulnerabilities.


I found a work around. (Edit: sometimes certain creases still wont show. or will be in the wrong place)
In 3ds max
In your “Edit Poly” options in the “Modify Tab”, go down to “Subdivision Surface”
Check “use NURMS subdivision”
Set Display Iterations to zero
Then apply another “Edit Poly” modifier ontop of your model
You can then export as .FBX

Import into rhino
On the import options do NOT check “import as subD”, just import as a normal model
The creases should now be in the right place
Then convert it to subD yourself with the “convert to subd” button in the “subD Tool” tool bar
Make sure the setting are correct like “MeshCrease=yes” and “UseMesh=Controll points”

1 Like