Fancy new laptop, but executing commands in my models is SLOW


I recently purchased an HP Omen laptop with a RTX 3080 Ti (laptop) GPU and an i7 12800HX CPU, and 32 GB of RAM.

I was hoping it would handle a very detailed large Rhino model I am working on (file size is about 1GB). After reading the threads on this forum, I optimized my GPU settings and Window OS settings to use the RTX card per the instructions. I even went into my device manager and disabled the Intel GPU.

However, despite all that I am finding that it takes FOREVER to merely ‘select’ objects in my 3d model or execute simple commands such as creating a cube when I am in shaded mode. Doesn’t matter how zoomed into geometry I am… selecting something or creating something takes 5-8 seconds every time. Obviously that makes using the laptop for my work totally impossible. Just orbiting in the viewport and looking around the model and the latency seems fine, however.

I assumed this laptop would handle the model fine since I have an HP Omen desktop with an RTX 3070 and i9 and this is not an issue at all. Sometimes when I have all of the geometry shown in a viewport it feels more laggy on my desktop, but not to this extreme extent.

Does anyone have an idea what the huge slowdown in shaded mode is all about?

Have you tried different GPU drivers? Also I have a feeling there is something to do with the integrated GPU from Intel.

Hi @James_Kehl can you run _SystemInfo and post back the results here?

Hi all, here is a link to my laptop’s specifications.

Attached is a .txt readout of _SystemInfo.
System Info.txt (2.7 KB)

This is driving me nuts… if anyone can help me solve this will send you a starbucks card…

The GPU seems to be handling the viewport latency fine, and handles Enscape like a champ… it’s just when I’m executing commands or selecting objects that the slowness occurs. I think this suggests it is a bottleneck with my CPU? I just didn’t think my CPU would be this bad?

Do you have these settings? Are you seeing the same behavior if you run Rhino in Safe Mode?

Re-Reading your initial post it might be the shear number of objects being processed. Do you require all the objects to be on in the view? Turning off layers and particular object types is a good way to troubleshoot this. I would start with Text / Dimension objects, then curves. Are these objects really far away from the 0,0,0?

Hi Japhy, yes I have changed the settings per that post. I have disabled the Intel GPU as well so it is definitely not active.

I agree there is a relationship to the number of objects in the scene and the lag I am experiencing. However, on this laptop the lag is very extreme with this file compared to my other computers I use. I have to hide almost everything in the scene before the lag disappears entirely. It doesn’t feel right to me. Safe mode doesn’t help unfortunately.

Can you zip and send us the file privately? upload to mcneel I’m running an RTX 2070.

Can you provide the SystemInfo on this machine as well? Thanks.

The specs on my desktop are here:

The _SystemInfo on my desktop is attached.
System Info_desktop.txt (2.8 KB)

You can download the file here:

Thanks, we’ll take a look.

A couple differences are Nvidia driver version and enscape versions.

I’ve been having constant issues with lag too, especially when undo/redo and copy/paste. Have very little on the screen with file size of 360MB. I’ve just switched from Mac to PC, same problem, it’s agony.

no issues here, very responsive for a large model, especially considering i have 3 revit projects & several instances of Rhino open currently.

Are these on the other machine as well?

Hi Alasdairjmckay, Can you start a new thread and we can look into your issue? Thanks

Wow really it’s responsive and working fine for you? I’m surprised, what kind of CPU are you using? Do you have an opinion on whether this is a CPU-driven issue? Could this have something to do with Rhino settings?

No, the files were not on the machine but I have just removed those missing image files within Rhino and it has not improved anything.

I’m always uninstalling the latest to test regressions in older versions and keep all the graphics settings default. A repair install of Rhino will give you a clean setup.


This seems like a graphics processing issue (driver?)

My processor is intel(R) Core™ i9-10900K CPU @ 3.70GHz, 3696 Mhz, 10 Core(s), 20 Logical Processor(s)

Here are the loads i'm seeing..


Well, I don’t know… I tried changing the driver to NVIDIA’s studio driver, and then backdating to the version my desktop has, which was problematic. I reinstalled the Game Ready driver and am still having this issue. I don’t know what it could be other than the processor. Enscape and the viewport latency are good it’s just executing commands and selecting things which seems like a CPU issue.

Just for testing purposes, what happens if you disable Enscape and all other Plug-ins that do not shipw with Rhino, Restart Rhino, and try it again.
Any difference?

Holy crap… I just figured it out. I connected a second monitor to my laptop and opened Rhino using it as my primary display. Lo and behold, it works like a charm now.

This setting is the culprit:

By default on my laptop (which is a ‘gaming’ laptop), the secondary Intel GPU is responsible for the laptop display. This results in the lag, despite me actually requiring Rhino 7 to be opened with the Nvidia GPU in my control panel settings.

I am running into trouble because when I disable the Intel GPU and attempt to globally use the Nvidia GPU, Windows forces the laptop display onto ‘Microsoft Basic Display Adaptor’ rather than the Nvidia GPU.

I’m really confused now… Not sure how to get the laptop display to rely on the Nvidia GPU. Apparently it knows what to do if I plug an external monitor in. It’s a weird problem. Any ideas?

See if this helps: