Failed to fetch package from source

package manager
Hello When I open the package manager, I get this message: Failed to fetch packages from source(s): ‘https://yak.rhino3d.com’ Internet access disabled by Rhino. Are you sure there’s a package server/folder here?

What does that mean? How do I fix it?

@will - any idea?

-Pascal

This means that Rhino has been configured to prevent it accessing the internet. If you didn’t do this, then you’ll need to talk to whoever installed Rhino on your machine.

Thank you Will. Is there a way to not use the internet? Like place a folder with the plug-ins in it and have Rhino go look there? I tried this. I went to advanced and replaced the internet location to a local location. I didn’t get the same error message. but nothing was listed for me to install. When I try to manually place Grasshopper software in the components folder, Grasshopper does not see them…

The package manager will look for .yak files in the folder that you’ve specified as a local package repository. You can get these files from the API, but it isn’t super user-friendly.

For example, https://yak.rhino3d.com/versions/panelingtools will give you a list of PanelingTools versions with download links.

Do you have an example of which Grasshopper plug-in you’re trying to install? There are a few ways to install plug-ins, so knowing which one will help. :slight_smile:

Hi again. The plug-ins I want are nothing special. I have them on my personal computer, but this is a General Motors computer. I want to install Pufferfish, Lunchbox, parakeet, Weaverbird, panel Tools, Dendro, Stella3d and Anemone. I have tried the Package manager and tried manually placing the files in the components folder. Nothing works. I have no problem with my personal machine. Our IT guys are not familiar with Rhino and aren’t much help. There is a small group of Rhino Users at GM. We meet once a week. I hope to have a solution for my colleagues.

Thanks

I have heard from our IT, back east. They have blocked the WEB installation of plug-in’s.

Our IT department re-installed my rhino 7. The package manager still doesn’t work. I have been able to install several grasshopper plug-in’s, the old fashion way, in the components folder. Lunchbox has it’s own installer. But nothing with the Package manager

Hi Frederick -

I wouldn’t have expected a reinstalling of Rhino to change that. It’s the access to the web that needs to be opened.
-wim