Exporting for CNC milling DWG doesn't like Rhino Curves - Solved


The machine shop is giving me an earful about how my Rhino curves are exploded into a thousand different points in autocad. I have run into this issue myself before.

Is there anyway to fix this? Possibly export first to Illustrator or a setting in Rhino?


G-Code supports three movements, a line between two coordinates, a clockwise arc, and an anti-clockwise arc.
You need to do the extra work in Rhino so only lines and arcs are exported.
The CAM Imperial and CAM Metric DWG/DXF export schemes have the export settings fixed.
However, before you save it out, you need to convert the curvy line (not lines, circles, and arcs, but everything else), to chains of arc segments.

Use the Convert command to make arcs. Set the Angle tolerance to zero to disable it. Then use the Tolerance to control how far you are comfortable with allowing the chain of arcs to pull away from your NURBS curves. The dots on the preview will show you the arc it will replace your NURBS curve with.

The problem is if you don’t convert to arcs first, Rhino NURBS curves will be approximated with short, straight line segments that approximate the smooth NURBS curve.


Thank you Brock. It is very interesting how other programs interpret NURBS. I will employ your suggestions now.
I appreciate the feedback!

Brock, that was as direct and straight to the point explanation of the limitations and downfalls of DXF export for G-code CNC milling as I have ever seen. You cut right to the crux of the matter, thanks!

Many CAM applications can read IGES files in addition to DXF. Most of these do the arc conversion for you, on the fly when generating G-code tool paths.
If your CAM tools support IGES files, try a test and see if you can skip the arc conversion before exporting to the more limited DXF file format.

The difference is IGES files support NURBS curves where DXF does not.

1 Like