Executing Grasshopper file from CPython _ Exception

Hello @stevebaer,

I am reporting an exception as trying to execute a Grasshopper file from VisualStudio Code/CPython3.7 via Rhino.Inside.

Everything works perfectly (I can write inputs and read outputs) as soon as the Grasshopper file I want to execute does not contain a scripted GhPython component. In that case, VisualStudio fails in retrieving outputs from any component downstream to the GhPython.

Scripted c# components work fine.
I guess there might be some issues with the two different Python executables running in parallel?

I attach the CPython code (RhinoInside_GhSolution.py) and two Grasshopper files.
test_vanilla.gh delivers , test_GhPython.gh fails.

Is this issue solvable?

Thank you,

RhinoInside_GhSolution.py (2.0 KB)
test_ghPython.gh (5.1 KB)
test_vanilla.gh (3.4 KB)

This should work. I’ll try to get this tested in a local debug version of Rhino to try and figure out what is happening.

I just ran your script using both test_vanilla.gh and test_ghPython.gh and got the same results (i.e. they both worked). Do you have 3rd party components installed that may be interfering?

Hi Steve,

thanks for your feedback.

I tried to uninstall all third party libraries on the Grasshopper side as well as some unnecessary libraries from the Python side and still had no outputs downstream the Gh-Python component.

Do you have in mind any particular python library which may interfere?

Thank you,

Hi Steve, I’ve just updated to the last version of rhinoinside and this apparently solved the issue.

1 Like