Errors of components in grasshopper

I don’t understand the meaning of the error messeges, I mean that I don’t know what can I do .
I tried to follow red wires and I made (kinks) true , but that doesn’t solve the error.

There is no point in following red wires as they have no data/geometry. That’s the problem.
Errors can appear if one or more items in a data tree fail, even though the rest succeed. Use text panels to examine the output of each component, especially the red ones.

Related thread:

What is the meaning of ( object reference not set to an instance of an object) ?

I made (kinks) of divide curve component true , but nothing done .

What must I do to solve this problem?


Please learn how to take screen snapshots without using a camera (WindowsKey-PrintScr).

Connect the panel to outputs earlier in your code. In this case, I’m guessing that one or more of the planes don’t intersect one or both of the curves, so points being passed to Line are null.

Examine the output of every component in your code and understand it before connecting more components downstream.

And please don’t start multiple threads on the same subject. Context and all previous advice is lost that way.

Ok .
Thank you so much.

There’s really problem in points of curves .
And I’m sorry for any mistake I had done ,
I will takecare the next time .

We all make mistakes, that is not a problem. The biggest mistake, however, is not posting a Grasshopper file. It requires much more effort and is less effective to help, since so many questions would be answered by just looking at your code (and internalized geometry!). Too much relevant information is missing from screen shots and written descriptions.

If I guessed correctly(?), there are additional steps to avoid “bad data” being passed along to other components, including Clean Tree (with ‘E’ input set to ‘True’ to remove nulls) and Prune Tree to ignore branches that don’t have two points.

Good luck and have fun.

If I send grasshopper file only , it will not work .
But if I send rhino.3dm file with grasshopper file it will work .
Can I send both files (rhino + gh) ?

Thank you so much .
Using trees really is a very good idea .:smiley:

I used flatten tree to remove all branches and this solve the problem.

Before using flatten tree :point_down:

After using flatten tree :point_down:

Yes. Or you can internalize geometry in the GH file so the Rhino file isn’t needed.

Apparently you missed this on the list of tips about How to ask effective questions

3. Attach minimal versions of all the relevant files
If you have a gh file you have a question about, attach it to the post. Do not expect that people will recreate a file based on a screen-shot because that’s a lot of pointless work. It’s also a good idea to remove everything non-essential from a gh file. You can use the Internalise Data menu option to cut everything to the left of a parameter:

If you are referencing curves or breps or meshes from Rhino, you can also internalise them so you won’t have to post a 3dm file as well as a gh file. If you’re unsure whether all the relevant data is internal to the gh file, try opening it in an empty Rhino. Does it work? Good. No? You’ll need to internalise more.

Flatten is not the only way to fix the problem. It will cause many models to fail completely, since preserving the tree/branch structure is often necessary. That’s why I mentioned Clean Tree and Prune Tree as alternatives in this case. Shift Paths is another very useful component to avoid flattening a tree in some cases.

Understanding your data trees is essential to success with Grasshopper.

First of all, i should say that I learned many things here and the information you told me is very important and useful. Thank you so much.

(Shift paths) really too is very useful component and solved the error also.

(Flatten tree) didn’t cause any problem to my case and I can use (graft tree) to make branches for data but I didn’t need it so (flatten tree) was enough for me to solve the problem of my case.

When I used (clean tree) and (prune tree), panel read nothing and the error didn’t disappear because there was no data entered to the component.
I thought that (clean tree) cleared all data , so I tried to use another tree to solve the problem of null branches.