Elevator mode on Mac

Does elevator mode work on mac? if so which is the hotkey?

Cmd replaces Ctrl for Windows–> MacRhino…

–Mitch

I tried this and it works but for some reason Ortho is disabled. I’m new to Rhino and may not understand the elevator function. Any idea what I might be doing wrong?

elevator mode is a bit of a weird one to get used to (or it was for me at least) since i kept thinking i’d push a key and the thing goes vertical…

you have to hold cmmd then click on the point you’d like to go vertical from… say you want to draw a vertical line (there are better ways to draw a vertical line but just for example)

• run the _Line command
• click in the perspective viewport to set the first point
• cmmd-click on that point again to go into elevator mode… the line will now be constrained to the Z axis.

i had accuracy issues when first trying that so pretty much after you set the first point, move the cursor off the point then bring it back ensuring you’re getting a ‘point’ snap prior to activating elevator mode.

elevator is more powerful than just drawing vertical lines but it takes a minute to see what else it can do… still, i sort of wish there was a dumber mode in which a key press only does one thing which forces vertical from the start point.


re: ortho
if you push the O key, ortho will toggle on/off (the indicator is in the toolbar at the top of the window)… i generally leave ortho off though and use the shift key to temporarily turn it on… (and i do this a lot).
but i guess you’ll have to experiment with it to see what works best for you.

Hello Jeff - Thanks for the quick response. I think I got all that. My problem is neither the shift nor the O key do anything. The Ortho button changes but it does nothing.

I’m working my way through the “Training Manual Level 1” and “Exercise 24” introduces elevator mode. The elevator command works in the sense that the end point is constrained to a line emanating from the selected point perpendicular to the “eleveated” plane but it will not snap to that plane. I kind of makes the mode useless. Not sure if that explains the issue and sorry for not explaining better the first time. I’m wondering if the Mac version has a bug. Ortho does work, but just not here. Does it work on a PC?

Normally when you click a point, Rhino gets X, Y and Z values with the single click.
Elevator mode give you a second click to set the CPlane Z.

Start a command that prompts for a point, like Circle.
With your pointer in the Perspective view, press and hold Ctrl (Cmd in OSX).
Click a point.
Release Ctrl (Cmd)
Move your cursor and watch the white line indicate a point normal to the CPlane.
Click a second point to pass the missing Z value to the already known X, Y.

You just did Elevator Mode.

ortho works on both mac and pc…
what are you thinking it’s supposed to do?

a simple way to see it in action would be:
• go to the Top viewport
• turn ortho on
• run the _Line command
• click the first point of the line
• notice youre constrained to 90º… ortho has locked on to only the x or y axis (and this setting is changeable… you can change it to say, 45º then the line will be able to go in 8 different directions instead of 4)

do you see what it’s doing?

also, do the same steps as above except turn ortho off… when you’re moving the cursor around for the second point of the line, press & hold the shift key… this is temporarily engaging ortho and it will snap your line to the nearest 90º increment…

does that work for you?


in the exercise you’re working on, what are you expecting to happen? there is probably another way to do what you’re expecting… just that i don’t think it’s ortho you’re looking for…
ortho won’t work in conjunction with elevator mode since elevator is constraining to the Z axis whereas ortho is working on the XY plane.

I am working in the perspective view during some stages of constructing a piece of furniture, in order to snap between an element in the xY plane and one above it in the z direction. I am getting the hang of the elevator mode, thanks to the help on the forum, however I do not seem to have any snaps even with OSNAPS enabled or toggling them on and off with the ALT key. Any one have any ideas?

I think I get it now. I was expecting ortho to work while in elevator mode. I thought I should be able to draw a line on the xy plane and using elevator, draw a another line directly above and parallel to the first. I see now, that I can do this but not the way I expected.

I started with all snaps and ortho off. In Top view I drew a line on the xy plane from point “A” to point “B". In Front view, I next draw a line perpendicular to the first by placing the curser over end point “A” of my previously drawn line with End snap on and then holding down the shift key moving the curser up and click. So far, so good. Shift is toggling ortho on. I start a new line from the upper end point of this second line. I then hover over point “B” of my first line and command click. The end point of my third line is now anywhere I choose in z but constrained to the xy coordinates of point “B” of my first line. I am expecting that by holding down the shift key, my line will snap parallel to the xy plane but it does not.

I now realize that if I click on the upper end point of the second line I drew (my start point), or type in the length of my second line, I get what I was looking for.

Thanks again for taking time to help with this.

Hi Jeff, thanks for these tips. I used to have a different workflow, but your description sounds a lot easier.