Element type Picker component exception

every time i use the Element type picker i get this error

Which version of Revit?

revit 2021

I can confirm it works in 2020. Kinda looks like it lost context (doesn’t know its revit doc)

Doesn’t seem to work for Revit 2019.2 either! This is with Rhino 7

i’m in 2019.2 today and it is working, per the last release of RiR (0.1)

The general problem here is the the Type selector is an older component that only selects from the active document. So it is one of the components that will get confused when multiple docs are open.

When there is only one doc open, do you still see the errors?

We plan to rewrite the selector so it will work better in multi-docs environments.

it was happening with just one file open but it is resolved in the 0.1 build, I have used the component multiple times now and have not encountered the error again

I’m having this problem too.

Revit 2020
rhino 7

I had this pop before but it worked, today this component is not working.
I’ll try restart revit.

Johan, What is the release number of your Rhino.Inside.Revit?

Are you in a Project or Family revit document?

Although both work Built-In Categories > Query Types > Element Type Picker would allow for filtering of possible large Type selections first.

I noticed that i didn’t updated rhino.inside. Now i did, but the problem keeps showing:

This is my scenario:

Following this. Today I tried again and it worked, but I noticed something.
If you see my previous image “Basic Wall 300mm” is selected but this element is not actually present in the file so it’s obvious that this wont show nothing. I proceeded to select other kind of wall and it worked, but the component exception keeps showing every time introduce the element type picker in grasshopper.

When i open the file and some of the element type pickers are activated and fed by the built in category, all the exception warnings show on a row. Kind of annoying.

The element type picker that can’t read any element have this red warning:
“object reference not set to an instance of an object”

Then I select other element and go back to this one and the component doesn’t have the warning.

I just think this is a weird behavior. At least in my part.

I hope you check this out.

Thanks for the great info, makes it much easier to figure out what’s going on. I haven’t been able to reproduce it.

So the Element Type Picker is getting populated by Types in a file, then when you open the same definition in a new file sans types, it throws the exemption.

I am also having problems with the Element Type Picker (ETP) throwing and exceptions (A). But, this also makes some of the typing in Grasshopper unresponsive after plugging the
ETP into the script. I see that I get a warning error in the Rhino command line that gets stuck and refreshes ever few seconds (B).

I’m not sure if these two malfunctions are related but any time I’ve tried to use the ETP I loose some keyboard functionality and have to close Revit and Rhino and start over.

Rhino.Inside Revit: 1.3.7983.15227 (11/09/2021 08:27:34)

Rhino: 7.12.21313.06341 (Rhino 7)
Revit: 2021.2 (

Try a value picker instead.

Can you also try the 1.4 release candidate?

No errors on my end but a different version of Revit & RiR, i can try your setup tomorrow.